The 3n + 1 problem

题目描述

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22

输入

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0

输出

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input

样例输入:

1 10
100 200
201 210
900 1000

样例输出:

1 10 20
100 200 125
201 210 89
900 1000 174
#include <stdio.h>
int main()
{
	int  i, j, k=1,m,n ;
	int s[1000];
	int a,b,c;
	while (scanf("%d %d", &a, &b) != EOF)
	{

		for (i = a; i <= b; i++)
		{
			j = i;
			k = 1;
			while (j != 1)
			{
				if (j % 2 == 0)
				{
					j = j / 2;
				}
				else
				{
					j = j * 3 + 1;
				}
				k++;
			}
			s[i] = k;
		}

		for (m = a; m <= b; m++)
		{
			for (n = a; n < a + b - m; n++)
			{
				if (s[n] > s[n + 1])
				{
					int temp = s[n];
					s[n] = s[n + 1];
					s[n + 1] = temp;
				}
			}
		}
		printf("%d %d %d\n", a, b, s[b]);
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值