恶心的大数:E - Easy Basic remains

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.
Input
Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.
Output
For each test case, print a line giving p mod m as a base-b integer.
Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789

注意!注意!注意!!!看完该篇博客,各位同志一定要去学java,java对大数运算真实太™好了,用C++模拟太慢了,,,,,,,,,,,,,,,,,,一定要去学java大数,,,一定要去!!!

思路:(好吧!我 是没有想到的,居然从其它进制数的高位化为十进制数,我以前一直用低位上乘来着。。。好像做过一道类似的题目: H - Lotus and Character

代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <ctime>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <bitset>
using namespace std;
#define ll long long
#define MAXN 50005

char s1[1005], s2[15];
int f[15];
int main()
{
    int n;
    while(scanf("%d", &n) && n)
    {
        scanf("%s%s", s1, s2);
        int len1 = strlen(s1);
        int len2 = strlen(s2);
        ll a=0, b=0;
        for(int i=0; i<len2; ++i)//从最高位求十进制数
            b = b*n + s2[i]-'0';
        for(int i=0; i<len1; ++i)//从高位求十进制数,然后mod,保证不会爆long long
        {
            a = a*n + s1[i]-'0';
            if(a>=b)
                a%=b;
        }
        if(!a)
            cout << 0 << '\n';
        else
        {
            int x=0;
            while(a)
            {
                f[x] = a%n;
                a/=n;
                x++;
            }
            for(int i=x-1; i>=0; --i)
                cout << f[i];
            cout << '\n';
        }
    }
    return 0;
}

赛后看人家的代码,全是用java, 就一个队伍用了C++。。。。。
So,同志们,赶紧去学java, 真香警告!警告!!警告!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值