HDU - 2619 Love you Ten thousand years

Love you Ten thousand years------Earth’s rotation is a day that is the representative of a day I love you. True love, there is no limit and no defects. Earth’s revolution once a year, it is on behalf of my love you more than a year. Permanent horizon, and my heart will never change ……

We say that integer x, 0 < x < n,(n is a odd prime number) is a LovePoint-based-on n if and only if the set { (x i mod n) | 1 <= i <= n-1 } is equal to { 1, …, n-1 }. For example, the powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a LovePoint-based-on 7.
Now give you a integer n >= 3(n will not exceed 2 31).
We say the number of LovePoint-based-on n is the number of days the earth rotating.
Your task is to calculate the number of days someone loved you.
Input
Each line of the input contains an integer n. Input is terminated by the end-of-file.
Output
For each n, print a single number that gives the number of days someone loved you.
Sample Input
5
Sample Output
2

题意:一个x(0 < x < n,n是素数),如果集合{ (x i mod n) | 1 <= i <= n-1}等于集合{ 1, …, n-1 }我们叫x是n的一个爱点,现在给出一个n,让你求n有多少个爱点。
思路:根据原根的定义:g^φ§对p取模等于1我们可以得出g ^ i(1<=i<=φ§)都不同(在区间1~p-1上),当p是素数时φ( p)=p-1,所以我们看出这里的爱点就是原根,题目就时求原根的个数,这个我们有公式:φ( n-1)

AC代码:

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
typedef long long LL;
int phi(int x){
    int ans = x;
    for(int i = 2; i*i <= x; i++){
        if(x % i == 0){
            ans = ans / i * (i-1);
            while(x % i == 0) x /= i;
        }
    }
    if(x > 1) ans = ans / x * (x-1);
    return ans;
}
int main()
{
    LL n;
    while(scanf("%lld",&n)!=EOF)
    {
        LL t;
        t=phi(n-1);
        printf("%lld\n",t);
    }
}

额(⊙﹏⊙),一开始理解错题了,以为要求n的原根。。。。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值