hdu2588 GCD

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3
1 1
10 2
10000 72
Sample Output
1
6
260

题意:给定整数N和M,多少整数X满足1<=X<=N和gcd(X,N)>=M

思路:x和N的最大公因子当x被N整除时是最大的情况,所以若x<M那不可能存在满足条件的x,所以M<=X<=N。当X是N的因子的时候满足gcd(X,N)=X>=M,也满足gcd(kX,N)=X>=M(k是素数,唯一分解定理),要求出满足条件的个数只要求出M<=X<=N条件下能被N整除的数以及它们的素数倍(欧拉函数)

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
#define ll long long
ll gcd(ll a,ll b)
{
    if(b==0)return a;
    else
        return gcd(b,a%b);
}
int phi(int x)
{
    int ans = x;
    for(int i = 2; i*i <= x; i++)
    {
        if(x % i == 0)
        {
            ans = ans / i * (i-1);
            while(x % i == 0) x /= i;
        }
    }
    if(x > 1) ans = ans / x * (x-1);
    return ans;
}

int main()
{
    int t;
    ll n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&m);
        ll ans=0;
        for(ll i=1;i*i<=n;i++)
        {
            if(n%i)continue;
            if(i>=m&&i*i<n)
                ans+=phi(n/i);
            if(n/i>=m)
            ans+=phi(i);
        }
        printf("%lld\n",ans);
    }

    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值