1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^​31).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

思路:

找一个数n的所有因子里面最长的连续因子串。i从2开始遍历,如果i是n的因子(n%i==0),那么从i开始找连续的因子串,更新max_len。注意的因子最大不会超过sqrt(n)。
如果max_len为0,那么说明n是2或者素数,最长连续因子长度为1。

源码:

#include<bits/stdc++.h>
using namespace std;
vector<int> factor,answer;
int max_len=0;
int main()
{
    int n;
    cin>>n;
    for(int i=2;i<=sqrt(n);i++)
    {
        if(n%i==0)
        {
            int t=n/i;
            int num=1;
            factor.clear();
            factor.push_back(i);
            if(num>max_len)
            {
                max_len=num;
                answer=factor;//将answer中的内容全部删除,复制为factor
            }
            for(int j=i+1;j<sqrt(n)&&t%j==0;j++)
            {
                num++;
                t/=j;
                factor.push_back(j);
                if(num>max_len)
                {
                    max_len=num;
                    answer=factor;//将answer中的内容全部删除,复制为factor
                }
            }
        }
    }

    if(!max_len)
        cout<<"1\n"<<n<<endl;
    else{
        cout<<max_len<<endl;
        int f=1;
        for(vector<int>::iterator itor=answer.begin();itor!=answer.end();itor++)
        {
            if(f)
            {
                cout<<*itor;
                f=0;
            }
            else
                cout<<"*"<<*itor;
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值