1030 Travel Plan (30分)

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

思路:

dijkstra算法,最短路径可能有多条,此时选择花费最少的。运用二维结构数组表示图,vector数组存储每个结点的最短路径。需要额外创建dist、take数组分别动态更新每个结点的最短距离和花费。

源码:

#include<bits/stdc++.h>
#define Max 500
#define infinity 501
using namespace std;
typedef struct lengthAndCost{
    int len;
    int cost;
}way;
way graph[Max][Max];//图
int visited[Max]={0};//访问标记
int dist[Max];//每个点的最短路径
int take[Max];//每个点的花费
vector<int> path[Max];//记录路径
void dijkstra(int n,int m,int s,int d)
{
    visited[s]=1;
    take[0]=0;
    for(int i=0;i<n;i++)//初始化
        if(graph[i][s].len!=infinity)
        {
            path[i].push_back(s);
            take[i]=take[s]+graph[i][s].cost;
        }
    while(1)
    {
        int minindex=-1;
        int min=infinity;
        for(int i=0;i<n;i++)
        {
            if(!visited[i]&&dist[i]<min)
            {
                minindex=i;
                min=dist[i];
            }
        }
        if(minindex==-1)break;
        visited[minindex]=1;//找出当前最短距离点,纳入
        for(int i=0;i<n;i++)
        {
            if(minindex!=i&&!visited[i])
            {
                int len=dist[minindex]+graph[i][minindex].len;
                int cost=take[minindex]+graph[i][minindex].cost;
                if(len<dist[i])//距离更短,直接更新
                {
                    dist[i]=len;//更新最短距离
                    path[i]=path[minindex];
                    path[i].push_back(minindex);//更新路径
                    take[i]=cost;//更新花费
                }
                else if(len==dist[i]&&cost<take[i])//距离相同,考虑花费
                {
                    path[i]=path[minindex];
                    path[i].push_back(minindex);//更新路径
                    take[i]=cost;//更新花费
                }
            }
        }
    }
    path[d].push_back(d);
}
int main()
{
    int m,n,s,d;
    cin>>n>>m>>s>>d;
    for(int i=0;i<n;i++)//初始化图
        for(int j=0;j<n;j++)
            if(i==j)
                graph[i][j].len=0;
            else
                graph[i][j].len=infinity;
    for(int i=0;i<m;i++)//建图
    {
        int a,b,len,cost;
        cin>>a>>b>>len>>cost;
        graph[a][b].len=graph[b][a].len=len;
        graph[a][b].cost=graph[b][a].cost=cost;
    }
    for(int i=0;i<n;i++)//初始化最短距离
        dist[i]=graph[s][i].len;

    dijkstra(n,m,s,d);//迪杰克斯特拉
    for(vector<int>::iterator it=path[d].begin();it!=path[d].end();it++)
        cout<<*it<<" ";
    cout<<dist[d]<<" "<<take[d]<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值