codeup|1060 Are They Equal (25 point(s))

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.12310^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120
10^3 0.128*10^3

code

#include<iostream>
#include<string>

using namespace std;

int n;//有效位数

string deal(string s, int &e) {
    int k = 0;//s的下标
    while (s.length() > 0 && s[0] == '0') {
        s.erase(s.begin());
    }
    if (s[0] == '.') {//去掉前导零后是小数点,说明s是小于1的小数
        s.erase(s.begin());//去掉小数点
        while (s.length() > 0 && s[0] == '0') {
            s.erase(s.begin());//去掉小数点后非零位前的所有零
            e--;
        }
    } else {
        while (k < s.length() && s[k] != '.') {//寻找小数点
            k++;
            e++;//只要不碰到小数点就让指数e++
        }
        if (k < s.length()) {//while结束后k<s.length(),说明遇到了小数点
            s.erase(s.begin() + k);//把小数点删去
        }
    }
    if (s.length() == 0) e = 0;//删去前导零后s的长度变为0,说明这个数是0
    int num = 0;
    k = 0;
    string res;
    while (num < n) {//只要精度还没有到n
        if (k < s.length()) res += s[k++];//只要还有数字,就添加到res末尾
        else res += '0';//否则res末尾添加0
        num++;//精度加一
    }
    return res;
}

int main(){
    string s1,s2,s3,s4;
    cin>>n>>s1>>s2;
    int e1=0,e2=0;//e1,e2分别作为s1与s2的指数
    s3=deal(s1,e1);
    s4=deal(s2,e2);
    if(s3==s4 &&e1==e2){//主体相同且指数相同
        cout<<"YES 0."<<s3<<"*10^"<<e1<<endl;
    }else{
        cout<<"NO 0."<<s3<<"*10^"<<e1<<" 0."<<s4<<"*10^"<<e2<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值