HDU 5019:revenge of GCD【GCD】

Discription
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.

Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.

Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.

Sample Input

2 3
3 4

Sample Output

1 1
5 3

题意
求两个数第k大的公因数
若因子数小于k则不存在,输出-1.

思路
求出两个数最大公约数,然后求出最大公因数的所有因数,存到一个vector里,从大到小排序,输出第k个。
需要特判最大公因数是1的情况。

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;

int t,f;
LL x,y,k;
vector<LL>v;
bool cmp(LL a,LL b)
{
    return a>b;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        v.clear();
        scanf("%lld %lld %lld",&x,&y,&k);
        LL tmp=__gcd(x,y);
        if(tmp==1&&k==1)
        {
            cout<<1<<endl;
            continue;
        }
        else if(tmp==1&&k>1)
        {
            cout<<-1<<endl;
            continue;
        }
        for(LL i=1; i<sqrt(tmp); i++)
            if(tmp%i==0)
            {
                v.push_back(i);
                v.push_back(tmp/i);
            }
        if((int)sqrt(tmp)*(int)sqrt(tmp)==tmp)
            v.push_back(sqrt(tmp));
        sort(v.begin(),v.end(),cmp);
        if(v.size()<k)
            cout<<-1<<endl;
        else
            cout<<v[k-1]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值