正方形

引用文本
Problem Description
给出四个点,判断这四个点能否构成一个正方形。
Input
输入的第一行包含一个整数T(T≤30)表示数据组数,每组数据只有一行,包括8个整数x1, y1, x2, y2,x3,y3,x4,y4(数据均在-1000,1000 之间)以逆时针顺序给出四个点的坐标。
Output
每组数据输出一行,如果是正方形,则输出: YES, 否则,输出:NO。
Sample Input
2
0 0 1 0 1 1 0 1
-1 0 0 -2 1 0 2 0
Sample Output
YES
NO
Hint
Source

package kl;
import java.util.*;
class Judge{
	int x1,x2,x3,x4,y1,y2,y3,y4;
	void ju(int x1,int x2,int x3,int x4,int y1,int y2,int y3,int y4) {
		if((Math.sqrt(Math.pow(x2-x1,2)+Math.pow(y2-y1,2))== Math.sqrt(Math.pow(x3-x2,2)+Math.pow(y3-y2,2)))&&(Math.sqrt(Math.pow(x4-x3,2)+Math.pow(y4-y3,2)) == Math.sqrt(Math.pow(x4-x1, 2)+Math.pow(y4-y1, 2)))){
			if((Math.sqrt(Math.pow(x2-x1,2)+Math.pow(y2-y1,2))== Math.sqrt(Math.pow(x4-x1,2)+Math.pow(y4-y1,2)))&&(Math.sqrt(Math.pow(x4-x3,2)+Math.pow(y4-y3,2)) == Math.sqrt(Math.pow(x3-x2, 2)+Math.pow(y3-y2, 2)))){
				if(Math.sqrt(Math.pow(x3-x1,2)+Math.pow(y3-y1,2))== Math.sqrt(Math.pow(x4-x2,2)+Math.pow(y4-y2,2))){
				System.out.println("YES");
			}
			}
		}
		else {
			System.out.println("NO");
		}
	}
}
public class Main
{
    static public void main(String[] args)
    {
        Scanner in = new Scanner(System.in);
        int x1,x2,x3,x4,y1,y2,y3,y4,t;
        t = in.nextInt();
        for(int i= 0; i < t;i++) {
        x1 = in.nextInt();
        y1 = in.nextInt();
        x2 = in.nextInt();
        y2 = in.nextInt();
        x3 = in.nextInt();
        y3 = in.nextInt();
        x4 = in.nextInt();
        y4 = in.nextInt();
        Judge judge = new Judge();
        judge.ju(x1, x2, x3, x4, y1, y2, y3, y4);
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值