vue配置加出错

一、安装
安装脚手架工具vue-cli

  • 全局安装vue-cli
    windows在cmd输入npm install --global vue-cli
  • 创建一个基于webpack 模板的项目
    接着输入vue init webpack 项目名称
  • 填写配置信息
Project name :项目名称
Project description:项目描述
Author:作者
Vue build:如何构建项目
Install vue-router:是否安装路由
Use ESLint to lint your code:是否使用ESLint来规范我们的代码
Pick an ESLint preset:选择一个ESLint代码规范
Set up unit tests:是否需要自动化单元测试
Setup e2e tests with Nightwatch:是否需要自动化用户界面测试
Should we run 'npm install' for your after the project has been created?(recommend):在后续安装依赖包是是否使用npm install安装

安装完成后提示Project initialization finished!
启动项目

cd 项目名称
npm run dev

(在我的电脑上需要在命令行
在这里插入图片描述
c盘下启动)
项目启动后会显示你的项目网址,在浏览器输入这个网址就可以看到vue
再输入vue ui
刚刚安装vue的时候cmd输入vue ui 没有反应,一查才知道是版本号太低2.9.6,需要删除原本的版本安装新的。
cmd输入
npm uninstall -g vue-cli
npm install -g @vue/cli
安装好了4.2.3版本之后输入vue ui 就可以跳出vuetest了

发布了5 篇原创文章 · 获赞 0 · 访问量 53
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 数字20 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览