A Simple Problem with Integers POJ - 3468(区间更新 区间修改裸题)

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

树状数组做法

#include <map>
#include <set>
#include <list>
#include <cmath>
#include <deque>
#include <queue>
#include <stack>
#include <cctype>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <complex>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;
int n,m;
long long a[100010];
long long sum1[100010];
long long sum2[100010];
long long lowbit(long long x)
{
    return x&(-x);
}
void update(int x,long long d)
{
    for(int i=x;i<=n;i+=lowbit(i))
    {
        sum1[i]+=d;
        sum2[i]+=d*(x-1);
    }
}
long long ask(int x)
{
    long long ans=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        ans+=x*sum1[i]-sum2[i];
    }
    return ans;
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        cin>>a[i];
        update(i,a[i]-a[i-1]);
    }
    string s;long long d;int x,y;
    while(m--)
    {
        cin>>s>>x>>y;
        if(s[0]=='Q')
        {
            cout<<ask(y)-ask(x-1)<<endl;
        }
        else
        {
            cin>>d;
            update(x,d);
            update(y+1,-d);
        }
    }
	return 0;
}

线段树做法

在这里插入代码片
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值