POJ2823(Sliding Window)

Sliding Window

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
在这里插入图片描述
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input

8 3
1 3 -1 -3 5 3 6 7
Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

思路

这道题解法可以说是多种多样,由于序列是静态不做修改的所以做法至少有3-4种吧。

  1. 暴力做法,时间复杂度O(n^2)。

  2. 单调队列,时间复杂度O(n),静态序列。

  3. 线段树,时间复杂度O(nlogn),静态序列和动态序列都可以。

  4. RMQ(Range Max/Min Query),时间复杂度O(nlogn),RMQ只针对静态序列。

贴个线段树做法,单调队列暂时不会等等去get一手~

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#define lson k<<1,l,m
#define rson k<<1|1,m+1,r 
using namespace std;
const int inf = 1<<30;
const int maxn = 1e6+50;
int smax[maxn<<2],smin[maxn<<2],a[maxn];	
int ans[maxn],res[maxn];		
inline void build(int k,int l,int r)						//O(n) 
{
	if(l == r){
		smax[k] = a[l];
		smin[k] = a[l];
		return ;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	smax[k] = max(smax[k<<1],smax[k<<1|1]);
	smin[k] = min(smin[k<<1],smin[k<<1|1]);
}
int query_max(int k,int l,int r,int ql,int qr)				//O(logn)
{
	if(qr < l || r < ql){
		return -inf;
	}
	if(ql <= l && r <= qr){
		return smax[k];
	}
	int m = (l + r) >> 1;
	int s1 = query_max(lson,ql,qr);
	int s2 = query_max(rson,ql,qr);
	return max(s1,s2);
}
int query_min(int k,int l,int r,int ql,int qr)				//O(logn)
{
	if(qr < l || r < ql){
		return inf;
	}
	if(ql <= l && r <= qr){
		return smin[k];
	}
	int m = (l + r) >> 1;
	int s1 = query_min(lson,ql,qr);
	int s2 = query_min(rson,ql,qr);
	return min(s1,s2);
}
int main()
{
	int n,k;
	while(~scanf("%d%d",&n,&k)){
		for(int i = 1;i <= n;i++){
			scanf("%d",&a[i]);
		}
		build(1,1,n);k--;
		for(int i = 1;i <= n-k;i++){
			ans[i] = query_min(1,1,n,i,i+k);
			res[i] = query_max(1,1,n,i,i+k);
		}
		for(int i = 1;i < n-k;i++){
			printf("%d ",ans[i]);
		}
		printf("%d\n",ans[n-k]);
		for(int i = 1;i < n-k;i++){
			printf("%d ",res[i]);
		}
		printf("%d\n",res[n-k]);
	}
	return 0;	
} 

愿你走出半生,归来仍是少年~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值