数据结构实验之栈与队列二:一般算术表达式转换成后缀式

数据结构实验之栈与队列二:一般算术表达式转换成后缀式

              Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。
Input

输入一个算术表达式,以‘#’字符作为结束标志。
Output

输出该表达式转换所得到的后缀式。
Sample Input

a*b+(c-d/e)*f#

Sample Output

abcde/-f+

Hint
Source
提示
中缀表达式转换成后缀表达式。
首先创建栈并置空,然后依次检查中缀表达式每个字符,不同字符按不同情况处理:
(1).
若是操作数,就直接将存入字符串exp[]中。
(2).
若是‘(’则将其压入栈中。
(3).
若是‘)’则依次弹栈并存入字符串exp[]中,直到遇到取出和它匹配的‘(’为止,‘(’出栈丢弃。
(4)
若是操作符,如果栈空或者该操作符的优先级大于栈顶操作符则将其放入到栈中。如果该操作符的优先级小于等于栈顶操作符则弹出栈中的操作符存入字符串exp[]中,直到该操作符的优先级大于栈顶操作符或栈空,然后将该操作符入栈。当读到了中缀式的末尾时,如果栈非空则将栈中所有元素依次弹出存入字符串exp[]中,最后见‘\0’存入exp[]中,则exp[]中存储的就是后缀表达式。
原文:https://blog.csdn.net/winddreams/article/details/18365557

#include <stdio.h>
#include <string.h>
int f(char ch, char sh)
{
    if(sh=='(') return 1;
    if( (ch=='*' || ch=='/' || ch=='%')&&( sh=='+' || sh=='-')  )
        return 1;
    else
        return -1;
}
int main()
{
    int i = 0 , n , top = -1 ;
    char exp[1000] , str[1000] , ch ;
    while(scanf("%c", &ch) && ch != '#')
    {
        if(ch >= 'a' && ch <='z')
            exp[i++] = ch ;
        else if(ch=='(')
            str[++top] = ch ;
        else if(ch==')')
        {
            while(top!=-1)
            {
                exp[i++] = str[top];
                top--;
                if(str[top]=='(')
                {
                    top--;
                    break;
                }
            }
        }
        else
        {
            if(top == -1 || f(ch,str[top]) > 0 )
                str[++top] = ch ;
            else
            {
                while(top >=0 && f(ch,str[top]) < 0  )
                {
                    exp[i++] = str[top--];
                }
                str[++top] = ch ;
            }
        }
    }
    while(top != -1)
    {
        exp[i++] = str[top--];
    }
    exp[i] = '\0';
    printf("%s\n", exp);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值