L - Fantasy of a Summation (全排列+快速幂+快速乘)

If you think codes, eat codes then sometimes you may get stressed. In your dreams you may see huge codes, as I have seen once. Here is the code I saw in my dream.

#include <stdio.h>

int cases, caseno;
int n, K, MOD;
int A[1001];

int main() {
    scanf("%d", &cases);
    while( cases-- ) {
        scanf("%d %d %d", &n, &K, &MOD);

        int i, i1, i2, i3, ... , iK;

        for( i = 0; i < n; i++ ) scanf("%d", &A[i]);

        int res = 0;
        for( i1 = 0; i1 < n; i1++ ) {
            for( i2 = 0; i2 < n; i2++ ) {
                for( i3 = 0; i3 < n; i3++ ) {
                    ...
                    
for( iK = 0; iK < n; iK++ ) {
                        res = ( res + A[i1] + A[i2] + ... + A[iK] ) % MOD;
                    }
                    ...
                
}
            }
        }
        printf("Case %d: %d\n", ++caseno, res);
    }
    return 0;
}

Actually the code was about: 'You are given three integers n, K, MOD and n integers: A0, A1, A2 ... An-1, you have to write K nested loops and calculate the summation of all Ai where i is the value of any nested loop variable.'

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with three integers: n (1 ≤ n ≤ 1000), K (1 ≤ K < 231), MOD (1 ≤ MOD ≤ 35000). The next line contains n non-negative integers denoting A0, A1, A2 ... An-1. Each of these integers will be fit into a 32 bit signed integer.

Output

For each case, print the case number and result of the code.

Sample Input

2

3 1 35000

1 2 3

2 3 35000

1 2

Sample Output

Case 1: 6

Case 2: 36

题解:n个数,k重循环,取余mod。

由于可以出现重复。则全排列总共有n^k种,每一个数在每一位上出现的次数为n,设n个数之和为sum,则第一位上的总和为n^k/n*sum;又因为有k重循环,即k位,每一位的权都是一样的,再乘上k取余即可。数据可能有点水,不用快速乘也能过。

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
typedef long long ll;
int gcd(int a,int b){return b==0?a:gcd(b,a%b);}
int lcm(int a,int b){return a*b/gcd(a,b);}
ll quickpow(int a,int b,int mod)  //快速幂
{
    ll ans=1;
    while(b)
    {
        if(b&1)
            ans=(ans*a)%mod;
        a=(a*a)%mod;
        b>>=1;
    }
    return ans;

}
ll quickmul(int a,int b,int mod)//快速乘
{
    ll ans=0;
    while(b)
    {
        if(b&1)
            ans=(ans+a)%mod;
        a=(a+a)%mod;
        b>>=1;
    }
    return ans;
}
int main()
{
    int t,x=1;
    ll n,k,mod;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld%lld",&n,&k,&mod);
        ll ans=quickpow(n,k-1,mod);
        ll sum=0;
        for(int i=1;i<=n;i++)
        {
            int t;
            scanf("%d",&t);
            sum=(sum+t)%mod;
        }
        ans=quickmul(ans,sum,mod); //其实这里不用快速乘也能过,直接(ans*sum*k)%mod即可
        ans=quickmul(ans,k,mod);
        cout<<"Case "<<x++<<": "<<ans<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值