PTA练习题 1003 Emergency (25分) 【dfs最短路】


传送门:1003


1003 Emergency (25分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c​2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​​ to C​2.

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C​2​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4


题目大意:

给你 n 个城市, m 条道路,让你从 c1 点走到 c2 点,每个城市都有一定的救援队 的数量,问你从 c1 点走到 c2 点有多少条最短路径,同时找出可能的最大救援数。


解题思路:

就是一道最短路的题目,需要注意的是,题目要求我们在保证最短路的条件下,找到最大的救援队伍的数量。 那么我们首先应该先找到最短路径,同时注意题目所给路径的双向的,然后在用 dfs 找到最大救援数。


AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int N=1100;
int n,m,c1,c2;
int numt[N];
int roads[N][N];
int vis[N];
int sum,maxn,minn;
vector<int> g[N];
void dfs(int x,int cnt)//找到最短路的长度
{
  if(x==c2)
  {
    minn=min(minn,cnt);
    return;
  }
  int len=g[x].size();
  for(int i=0;i<len;i++)
  {
    int u=g[x][i];
    if(!vis[u])
    {
      vis[u]=1;
      dfs(u,cnt+roads[x][u]);
      vis[u]=0;
    }
  }
  return;
}
void dfs1(int x,int ans,int cnt)
{
  if(cnt>minn)//剪枝,已经超过最短路的不用继续搜
    return;
  if(x==c2&&cnt==minn)
  {
    sum++;
    maxn=max(maxn,ans);
    return;
  }
  int len=g[x].size();
  for(int i=0;i<len;i++)
  {
    int u=g[x][i];
    if(!vis[u])
    {
      vis[u]=1;
      dfs1(u,ans+numt[u],cnt+roads[x][u]);
      vis[u]=0;
    }
  }
  return;
}
int main()
{
  memset(roads,inf,sizeof(roads));
  memset(vis,0,sizeof(vis));
  scanf("%d%d%d%d",&n,&m,&c1,&c2);
  for(int i=0;i<n;i++)
  {
    scanf("%d",&numt[i]);
  }
  int a,b,c;
  while(m--)
  {
    scanf("%d%d%d",&a,&b,&c);
    roads[a][b]=c;//双向交通
    roads[b][a]=c;
    g[a].push_back(b);
    g[b].push_back(a);
  }
  sum=0,maxn=0,minn=inf;
  vis[c1]=1;
  dfs(c1,0);
  memset(vis,0,sizeof(vis));
  vis[c1]=1;
  dfs1(c1,numt[c1],0);
  printf("%d %d\n",sum,maxn);
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值