POJ 1700 Crossing River【经典贪心】

传送门:POJ 1700


Crossing River
Time Limit: 1000MS Memory Limit: 10000K
Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10

Sample Output
17



题意
只有一艘船,能乘2人,船的运行速度为2人中较慢一人的速度,过去后还需一个人把船划回来,问把n个人运到对岸,最少需要多久。

思路

这是一道经典的贪心算法例题。我们先将所有人过河的时间由小到大排序,我们考虑每次把过河用时最多的两个人送到对岸,可以想到两个最佳方案:

1、 首先最快的和次快的两个人过河,最快的人划船回来,耗时v[0]+v[1];然后最慢的和次慢的两个人
过河,次快的人划船回来,此时对岸有最慢和次慢的两个人,耗时v[n-1]+v[1];
总耗时:v[0]+2*v[1]+v[n-1]

2、首先最快的和最慢的两个人过河,最快的人划船回来,耗时v[0]+v[n-1];然后最快的和次慢的两个人过河,最快的人划船回来,此时对岸有最慢和次慢的两个人,耗时v[n-2]+v[0];
总耗时:2*v[0]+v[n-1]+v[n-2]

算一下就知道,除此两种之外的方案耗费时间一定更多。所以每次选取耗时最短的那个方案将耗时最长的两个人送至对岸而不影响其他人。

代码

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#define ll long long
using namespace std;
int t,n;
int v[1100];
int main()
{
  scanf("%d",&t);
  while(t--)
  {
    int sum=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
      scanf("%d",&v[i]);
    }
    sort(v,v+n);
    while(n>3)//两种方案每次留在对岸的都是最慢的两个
    {
      sum+=min(v[0]+2*v[1]+v[n-1],2*v[0]+v[n-1]+v[n-2]);
      n-=2;
    }
    if(n==3) sum+=v[0]+v[1]+v[2];//剩三个人,先最快的和第三快的人过河,最快的人回,然后最快的和次快的两个人共同过河;
    else if(n==2) sum+=v[1];//剩两个人,即为最快的和次快的,两个人过河,耗时v[1];
    else sum+=v[0];//仅剩最快的人,单独过河,耗时v[0];
    printf("%d\n",sum);
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值