Break Standard Weigh 模拟

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term “scales” for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input
There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ x, y ≤ 100

Output
For each test case, output the maximum number of possible special masses.

Sample Input
2
4 9
10 10
Sample Output
13
9

题目意思是说,给你两个砝码,将这两个砝码中的一个拆成任意两个砝码,然后用这三个砝码放在天平上,看最多可以表示多少种重量,输出可以表示重量种类最多的那一个。不要被固定思维给限制住了,砝码可以放在左右两边,左右两边都放的时候可以用右边的减去左边的来表示实际的重量。

比较像牛客网上的一道题,用-1,0,1来对应表示放左边、不放和放右边,用集合set来记录可以记录的情况,最后选取所有可能情况的最大值即可。由于数据量不是特别大,所以可以暴力。

AC代码

#include<iostream>
#include<set>
#include<cmath>
using namespace std;
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int x,y,maxn=-1;
		cin>>x>>y;
		for(int i=1;i<=x/2;i++)//拆第一个砝码,只需要拆到一半就可以,结果是对称的
		{
			set<int> s;
			for(int j=-1;j<=1;j++)
				for(int k=-1;k<=1;k++)
					for(int l=-1;l<=1;l++)
						if(j*i+k*(x-i)+l*y>0)
							s.insert(j*i+k*(x-i)+l*y);
			int temp=s.size();
			if(maxn<temp)
				maxn=temp;
		}
		for(int i=1;i<=y/2;i++)//拆第二个砝码
		{
			set<int> s;
			for(int j=-1;j<=1;j++)
				for(int k=-1;k<=1;k++)
					for(int l=-1;l<=1;l++)
						if(j*i+k*(y-i)+l*x>0)
							s.insert(j*i+k*(y-i)+l*x);
			int temp=s.size();
			if(maxn<temp)
				maxn=temp;
		}
		cout<<maxn<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ayakanoinu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值