vue项目npm install报错分析

前端 专栏收录该内容
2 篇文章 0 订阅

记录从github上下载vue项目源码的一个个坑

项目源码:GitHub地址 真的是一个非常非常好的模板 用到了很多新的技术

但是 在下载后 当我执行npm install的时候,出现了很多问题。

1、提示没有phython环境。经过百度得到结果,是由于缺少windows下的编译环境 ,这时候需要执行以下两个命令:
npm install -g node-gyp
npm install --global --production windows-build-tools
安装完成后 就可以继续重新执行 npm install
在执行 npm install 之前 最好删掉node_modues包 重新安装各种依赖
2、安装过程报错如下
在这里插入图片描述
这种情况就是下载某一个依赖失败,一般来说 执行 npm uninstall 依赖 先删除 再指定安装npm install 依赖 就可以
但是 很多时候依然解决不了问题 例如我自己的 就一直不能解决 困扰了我非常非常久的时间 下面的方法都是我了解到的 或许有用 但对我来说并没有解决问题 :重新安装node.js 删除node_moudes包重新npm install等等 。在这期间,我换了各种版本的node.js,尝试了很多方法!!!
因为在github上提到 尽量不要使用cnpm从淘宝上下载依赖 会导致各种bug,所以我一直没有使用。这就是相信大神的教训!!!
在这里插入图片描述
但是后来我想,反正安装不上了现在,用淘宝的试试吧。先安装了cnmp,命令是npm install -g cnpm --registry=https://registry.npm.taobao.org
然后使用cnpm install 依赖 成功安装 马云牛逼 阿里牛逼 !至此,困扰我的问题终于得到解决。
被墙挡了,却不提示有关的原因,让人摸不着头脑,npm使用的是国外的资源,由于墙的存在,下载失败。可以直接使用阿里的仓库,最后说一句,阿里牛逼!

  • 2
    点赞
  • 0
    评论
  • 1
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页

打赏作者

weixin_43850745

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值