zoj3696(泊松分布)

Alien’s Organ
There’s an alien whose name is Marjar. It is an universal solder came from planet Highrich a long time ago.
Marjar is a strange alien. It needs to generate new organs(body parts) to fight. The generated organs will provide power to Marjar and then it will disappear. To fight for problem of moral integrity decay on our earth, it will randomly generate new fighting organs all the time, no matter day or night, no matter rain or shine. Averagely, it will generate λ new fighting organs every day.
Marjar’s fighting story is well known to people on earth. So can you help to calculate the possibility of that Marjar generates no more than N organs in one day?

Input
The first line contains a single integer
T (0 ≤
T ≤ 10000), indicating there are
T cases in total. Then the following
T lines each contains one integer
N (1 ≤
N ≤ 100) and one float number
λ (1 ≤
λ ≤ 100), which are described in problem statement.

Output
For each case, output the possibility described in problem statement, rounded to 3 decimal points.

Sample Input

3
5 8.000
8 5.000
2 4.910

Sample Output

0.191
0.932
0.132

用到了泊松分布公式https://wenku.baidu.com/view/3b125d7f8e9951e79b89276f.html
刚才用 lf输出,一直不对,才改成了f

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t,n,i;
    double p,ans,tmp,m;
    scanf("%d",&t);
    while(t--)
    {
        cin>>n>>p;
        ans=1;
        tmp=1;
        for(i=1;i<=n;i++)
        {
            tmp*=p;
            tmp/=i;
            ans+=tmp;
        }
        ans*=exp(-p);
        printf("%.3f\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值