POJ3356- AGTC(dp)

Description:
Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:
·Deletion: a letter in x is missing in y at a corresponding position.
·Insertion: a letter in y is missing in x at a corresponding position.
·Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.
Illustration
A G T A A G T * A G G C
| | | | | | |
A G T * C * T G A C G C
Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct
This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like
A G T A A G T A G G C
| | | | | | |
A G T C T G * A C G C
and 4 moves would be required (3 changes and 1 deletion).
In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.
Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.
Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input
The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output
An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input
10 AGTCTGACGC
11 AGTAAGTAGGC
Sample Output
4

题意:
有两个字符串x和y,每次可以删除x中的字符,或者在y中添加一个字符,或者把x和y对应位置的字符变成一样的,问最少需要多少次才能使得x和y一样。

解法:
设dp[i][j]代表使得x的前i个字符和y的前j个字符一样的最小操作次数,则每次有三种选择:在dp[i-1][j-1]的基础上使得i和j一样(假若x[i]==y[i]则不用+1,否则要+1),在dp[i-1][j]的基础上删掉i位的字符,在dp[i][j-1]的基础上删掉j位的字符。
注意多测。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stdlib.h>
#include<cstring>
#include<set>
using namespace std;

int n,m;
char a[1000+5],b[1000+5];
int dp[1000+5][1000+5];

int main()
{
    while(scanf("%d%s%d%s",&n,a+1,&m,b+1)!=EOF){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=max(n,m);i++)dp[i][0]=dp[0][i]=i;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(a[i]==b[j])dp[i][j]=min(dp[i-1][j-1],min(dp[i-1][j]+1,dp[i][j-1]+1));
                else dp[i][j]=min(dp[i-1][j-1]+1,min(dp[i-1][j]+1,dp[i][j-1]+1));
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值