【简便解法】1084 Broken Keyboard (20 分)_16行代码AC

立志用最少的代码做最高效的表达


PAT甲级最优题解——>传送门


On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:
Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:
For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es

Sample Output:
7TI


题意:键盘上有一些键坏了, 给定字符串S1和S2,S1是本应该输出的正确字符串,S2是实际输出的字符串,问哪些键坏了。

算法逻辑:定义数组存放每个字母出现的次数,如果S1[i]!=S2[i] 并且这个字母时第一次出现,输出即可。


#include<bits/stdc++.h>
using namespace std;
int a[300] = {0}; 
int main() {
	string s, s1; cin >> s >> s1;
	int i = 0, j = 0;
	while(i != s.size()) 
		if(s[i] != s1[j]) {
			s[i] = tolower(s[i]);
			if(a[s[i]] == 0) cout << (char)toupper((s[i]));
			a[s[i++]]++;
		} else {
			i++; j++;
		}
	return 0;
} 

       ——爱所有人,信任少数人,不负任何人。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

来老铁干了这碗代码

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值