POJ NO.2386

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

  • Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.
Sample Output

3

读题费了很大的功夫,不知道什么是八连通。题意为一滩积水W 和 与其八连通(类似于扫雷中一个数字周围的八个格子)的积水视位同一片。求一共有多少个水洼(只要有一滩积水便可视为一个水洼) 做法为将每一摊积水和与其连通的积水消去(直到没有与之连通的积水) 视为一个水洼。

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
const int MAX_SIZE = 100;

int N, M;
char field[MAX_SIZE][MAX_SIZE + 1];

void dfs(int row, int col)
{
	field[row][col] = '.';
	for (int i = -1; i <= 1; i++){
		for (int j = -1;  j <= 1; j++){
			int tmp_row = row + i, tmp_col = col + j;
			if (tmp_row >= 0 && tmp_row < N && tmp_col >= 0 && tmp_col < M &&
			    field[tmp_row][tmp_col] == 'W'){
				dfs(tmp_row, tmp_col);
			}
		}
	}
}

int main()
{
	cin >> N >> M;
	for (int i = 0; i < N; i++){
		for (int j = 0; j < M; j++){
			cin >> field[i][j];
		}
	}

	int res = 0;
	for (int i = 0; i < N; i++){
		for (int j = 0; j < M; j++){
		    if (field[i][j] == 'W'){
				dfs(i, j);
				res++;
			}
		}
	}
	cout << res << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值