Holding Bin-Laden Captive!

Holding Bin-Laden Captive!

Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”
Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input

1 1 3
0 0 0

Sample Output

4

母函数题
思路:先将一分钱的可能组成遍历为1,而后对2,5进行区分,由其所能组成钱数与之前所钱数进行比较,将没出现过的(不为1)输出即可
蒟弱代码:

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstdlib>
#include<stack>
#include<queue>
#include<functional>
#include<stdio.h>
#include <queue>
#include<string.h>
#define PI 3.1415926535
#define MAX 10005
#define N 100005
#define M 5005
#define INF 0x3f3f3f3f
#define lowbit(x) (x&(-x))
#define fori(a,b) for(int i=a;i<b;i++)
#define mem(a,b) memset(a,b,sizeof(a))

using namespace std;
typedef long long ll;
const int maxn=1e6+5;

int num_1,num_2,num_5;
int mon[maxn];
int main()
{
    int i,j,k;
    while(cin>>num_1>>num_2>>num_5)
    {
        if(num_1 + num_2 + num_5 == 0) break;
        mem(mon,0);
        for(i=0; i<=num_1; i++)
        {
            mon[i]=1;
        }
        for(i=0; i<=num_2*2; i+=2)
        {
            for(k=0; k<=num_1; k++)
            {
                mon[i+k]=1;
            }
        }
        for(i=0; i<=num_5*5; i+=5)
        {
            for(k=0; k<=num_1+num_2*2; k++)
            {
                if(mon[k])//这里需要判断数是否存在在进行比较
                    mon[i+k]=1;
            }
        }
        for(i=1; i<=num_1+num_2*2+num_5*5; i++)
        {
            if(!mon[i])
            {
		//将cout<<i<<endl;放入,不可?
                break;
            }
        }
        cout<<i<<endl;
    }
    return 0;
}

另附

#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<sstream>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
#include<map>
#include<set>
#define MAX 1e5
using namespace std;
typedef int LL;
int main()
{
    int i,j,k,l,m;
    int a[MAX],b[MAX],c[]={0,1,2,5},x[5];
    while(~scanf("%d%d%d",&x[1],&x[2],&x[3]))
    {
        if(x[1]==0&&x[2]==0&&x[3]==0)
            break;
        m=c[1]*x[1]+c[2]*x[2]+c[3]*x[3];
        for(i=0;i<=m;i++)
        {
            a[i]=1;
            b[i]=0;
        }
        a[m+1]=0;
        k=x[1]*c[1];
        for(i=2;i<=3;i++)
        {
            k+=x[i]*c[i];
            for(j=0;j<=k-x[i]*c[i];j++)
            {
                for(l=0;l+j<=k;l+=c[i])
                {
                    b[l+j]+=a[j];
                }
            }
            for(j=0;j<=k;j++)
            {
                a[j]=b[j];
                b[j]=0;
            }
        }
        for(i=0;i<MAX;i++)
        {
            if(a[i]==0)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值