SDUT-2137-数据结构实验之求二叉树后序遍历和层次遍历

Problem Description

已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。
Input

输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。
Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。
Sample Input

2
abdegcf
dbgeafc
xnliu
lnixu

Sample Output

dgebfca
abcdefg
linux
xnuli

Hint
Source
ma6174

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct tree
{
    struct tree *left,*right;
    char data;
};

struct tree * creat(int len,char a[],char b[])
{
    int i=0;
    if(len<=0) return NULL;
    struct tree *t;
    t=(struct tree *)malloc(sizeof(struct tree));
    t->data=a[0];
    for(i=0;i<len;i++)
    {
        if(a[0]==b[i])
        {
            break;
        }
    }
    t->left=creat(i,a+1,b);
    t->right=creat(len-i-1,a+i+1,b+i+1);
    return t;
}
void backshow(struct tree *t)
{
    if(t==NULL)
    {
        return;
    }
    backshow(t->left);
    backshow(t->right);
    printf("%c",t->data);
}
void arrangeshow(struct tree *t)
{
    struct tree *treenode[55];
    int in=0,out=0;
    treenode[in++]=t;
    while(in>out)
    {
        if(treenode[out]!=NULL)
        {
            treenode[in++]=treenode[out]->left;
            treenode[in++]=treenode[out]->right;
            printf("%c",treenode[out]->data);
        }
        out++;
    }
}
int main()
{
    int t,len;
    struct tree *root;
    char a[55],b[55];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",a,b);
        len=strlen(a);
        root=creat(len,a,b);
        backshow(root);
        printf("\n");
        arrangeshow(root);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值