Centos(阿里云)下pip安装FastText报错:Unsupported compiler -- at least C++11 support is needed!

15 篇文章 0 订阅

写在前面

   博主在后续使用pyhanlp时,又出现了jvm错误,鉴于有本次调试错误的经历,立马就想到了可能是因为新的服务器(Centos)缺少某些
支持(此处缺少了基本的Java支持),所以大家在配置新服务器时,出现没遇见过的错误,一定要先想想是不是缺少了某些支持?

一、问题描述

在centos下pip安装FastText报错:Unsupported compiler -- at least C++11 support is needed!

二、问题分析

缺少c++11的支持,为何会出现这种错误?博主在其他服务器上安装时未曾遇见过此错误。
因该服务器为新购入(阿里云Centos),博主猜测可能是缺少一些基础支持。但是具体少什么?

三、解决问题

输入gcc --version

gcc (GCC) 8.3.1 20191121 (Red Hat 8.3.1-5)
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

gcc没问题

输入g++ --version

-bash: g++: command not found

发现问题,新的服务器没g++
Over!直接大力出奇迹!
执行如下命令:

yum install gcc-c++

OK,输入g++ --version

g++ (GCC) 8.4.1 20200928 (Red Hat 8.4.1-1)
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

再次尝试pip安装FastText,成功!
Over!大功告成!

四、结语

至此,本文到此结束!
关于 Centos(阿里云)下pip安装FastText报错:Unsupported compiler – at least C++11 support is needed! 已全部完成,祝各位学业有成!
此博文只做学习用途,无任何商业用途!
大大怪爱小乖乖!
研哥哥

  • 0
    点赞
  • 1
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论

打赏作者

Mr.Ygg

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值