1076 Forwards on Weibo

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]
where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5
forward 向前,这里应该是转发。。
目前的一道难度不是很大的,唯一要注意的是第i个人的关注情况的时候,不应该i.push_back(),应该是关注者.push(i),比如 1 关注了2,2发微博的时候要2->1
题意比较重要,剩下的就是简单的BFS,因为这里面有限制层数L,所以BFS最合适

#include<iostream>
#include<map>
#include<vector>
#include<queue>
#include<string.h>
const int maxn =1005;
using namespace std;
struct Node{
	int v,layer;
//	Node(int _v) {
//		v=_v;
//	}
};
vector<Node> Adj[maxn];
bool vis[maxn]={false};
int L,n;
int BFS(int s,int &num){
	memset(vis,0,sizeof(vis));
	queue<Node> q;
	Node start;
	start.v=s;
	start.layer=0;
	vis[start.v] = true;
	q.push(start);
	while(!q.empty()){
		Node top=q.front();
		q.pop();
		if(top.layer > L) break;
		num++;
		int u = top.v;
		for(int i=0;i<Adj[u].size();i++){
			Node next = Adj[u][i];
			next.layer = top.layer + 1;
			if(!vis[next.v]){
				q.push(next);
				vis[next.v] = true;
			}
		}
	}
}
int main(){
	cin>>n>>L;
	for(int i=1;i<=n;i++){
		int t,a;
		cin>>t;
		while(t--){
			cin>>a;
			Node node;
			node.v=i;
			Adj[a].push_back(node);
		}
	}
	int q,b;
	cin>>q;
	while(q--){
		cin>>b;
		int num=0;
		BFS(b,num);
		cout<<num-1<<endl;
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值