1114 Family Property

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child
​1
​​ ⋯Child
​k
​​ M
​estate
​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child
​i
​​ 's are the ID’s of his/her children; M
​estate
​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG
​sets
​​ AVG
​area
​​

where ID is the smallest ID in the family; M is the total number of family members; AVG
​sets
​​ is the average number of sets of their real estate; and AVG
​area
​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
写了差不多 50分钟,17分,原因实在找不到了,也参考了别人的代码,思路都差不多,我也没细看,但是自己的就是找不到哪里错了,自己思路还是很清晰的,那就这样吧,如果谁发现了告诉我下,虽然我感觉没人看= =

#include<iostream>
#include<cstdio>
#include<map>
#include<algorithm>
#include<vector>
const int N = 10005;
using namespace std;
typedef struct{
	int id,num;
	double avgestate,avgarea;
}people;
int father[N],estate[N],isroot[N],area[N],bk[N];
int findfather(int x){
	while(x != father[x]){
		x = father[x];
	}
	return x;
}
void Union(int a,int b){
	int fa = findfather(a);
	int fb = findfather(b);
	if(fa != fb){
		if( fa < fb) father[fb] = fa;
		else father[fa] = fb;
	}
}
bool cmp(people a,people b){
	if(a.avgarea != b.avgarea) return a.avgarea > b.avgarea;
	return a.id < b.id;
}
int main(){
	for(int i=0;i<=N;i++) father[i] = i;
	int n;
	cin>>n;
	for(int i=0;i<n;i++){
		int id,father,mother,num,cid;
		cin>>id>>father>>mother>>num;
		bk[id] = 1;
		if(father!=-1) {
			Union(id,father);
			bk[father]  = 1;
		}
		if(mother!=-1) {
			Union(id,mother);
			bk[mother] = 1;
		}
		for(int j=0;j<num;j++){
			cin>>cid;
			bk[cid] = 1;
			Union(id,cid);
		}
		cin>>estate[id]>>area[id];
	}
	int ans =0;
	vector<int> v;
    vector<people> p;
	for(int i=1;i<N;i++){
		if(bk[i] == 1 && father[i] == i){
			v.push_back(i);
		}
	}

		for(int j=0;j<v.size();j++){
			int root = v[j];
			int sume=0,suma=0,num=0;
				for(int i=0;i<N;i++){
					if(findfather(i) == root){
						++num;
						sume+=estate[i];
						suma+=area[i];
					}
			}
			double avge = sume*1.0/num;
			double avga = suma*1.0/num;
			p.push_back({root,num,avge,avga});	
		}
		sort(p.begin(),p.end(),cmp);
		cout<<p.size()<<endl;
		for(int i=0;i<p.size();i++){
			printf("%04d %d %.3f %.3f\n",p[i].id,p[i].num,p[i].avgestate,p[i].avgarea);
		}
	return 0 ;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值