1098 Insertion or Heap Sort

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9
第一次 21分,2个特殊点吧,应该是和原始序列相同的情况算插入
关键部分还是堆排序,掌握堆排序和注意排序的下标和特殊情况就可以了
其实严格老说哦我感觉这道题的插入判断机制很迷,算法笔记上说的是,比如
3 4 2 1
3 4 2 1
如果2次相同,算下一次,结果就是 2 3 4 1
但是我觉得如果 是 3 4 5 2 1的话按照算法笔记上的来说,结果还是3 4 5 2 1,但是按照插入排序应该是 2 3 4 5 1,有人肯定说 按照顺序来说3 4 5 2 1这种情况是存在的,确实但是 2 3 4 5 1也是存在的,如果按照顺序来说确实是3 4 5 2 1,也是= =,写到这里明白了,但是2 3 4 5 1是更后面的情况,有可能我题目没读清楚

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<map>
#include<vector>
#include<algorithm>
#include<queue>
const int N = 105;
using namespace std;
int a[N],b[N],c[N],target[N],n;
bool isSame(int aa[],int bb[]){
	for(int i=1;i<=n;i++){
		if(aa[i] != bb[i]) return false;
	}
	return true;
}
void downAdjust(int low,int heigh){
	int i = low, j = i * 2;
	while(j <= heigh){
		if(j+1 <= heigh && b[j+1] > b[j]) j=j+1;
		if(b[j] > b[i]){
			swap(b[i],b[j]);
			i=j;
			j=2*i;
		}
		else break;
	}
}
void prin(int a[]){
	for(int j=1;j<=n;j++){
				if(j == 1) cout<<a[j];
				else cout<<' '<<a[j];
			}
}
int main(){
	cin>>n;
	for(int i=1;i<=n;i++) {
		cin>>a[i];
		b[i] = a[i];
	}
	for(int i=1;i<=n;i++){
		cin>>target[i];
	}
    bool flag = false;
	for(int i=2;i<=n;i++){
		if(  isSame(a,target)  && i != 2){
			flag = true;
		}
			sort(a+1,a+i+1);		
		if(flag){
			cout<<"Insertion Sort"<<endl;

			prin(a);
			return 0;
		}
		
	}
	for(int i=n/2;i>=1;i--){
		downAdjust(i,n);
	}
	bool flag1 = false;
	for(int i=n;i>=1;i--){
		if(isSame(target,b) && i != n){
		 	flag = true;		
		}
			swap(b[1],b[i]);
			downAdjust(1,i-1);
		if(flag){
			cout<<"Heap Sort"<<endl;

			prin(b);
			return 0;	
		}
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值