1147 Heaps

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
独立写出来的= =,很开心,就是时间有点长,50分钟吧,关键是对堆,完全二叉树的下标,还有递归的掌握还是不熟练。
写的时候
1.完全二叉树的层次遍历是按顺序递增的,判断叶子节点 是根据当前节点 n ,n2 是否<=总结点数,右节点同理。
2.堆递归的理解还是不透彻,导致想递归大根堆和小根堆的时候费了一点时间,
3.我觉得比较关键的一点就是一点要判断当前节点是否有子节点,有的话在判断,不然在判断小根堆的时候,当前没有子节点会直接判断比2
n节点大,应为一般2*n节点是空节点就是等于0,所以会错误,这一点要仔细思考。

这题没怎么考堆的内容,不管是模板还是知识点,还是逻辑的思考都要快一点

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<map>
#include<vector>
#include<algorithm>
#include<queue>
const int N = 1005;
using namespace std;
int m,n,inde,a[N];
bool flag = true,flag1=true;
void ismax(int root){
	if(root  > n) return;
	if(root * 2 <= n){
		if(a[root] < a[root * 2] )
		flag=false;
	}
	if(root * 2 + 1<= n){
		if(a[root] < a[root * 2 + 1])
		flag=false;
	}
	ismax(root * 2);
	ismax(root * 2+ 1);
}
void ismin(int root){
	if(root  > n) return;
	if(root * 2 <= n){
		if(a[root] > a[root * 2])
		flag1=false;
	}
	if(root * 2 + 1<= n){
		if(a[root] > a[root * 2 + 1])
		flag1=false;
	}
	ismin(root * 2);
	ismin(root * 2+ 1);
}
void postorder(int root){
	if(root > n) return;
	postorder(root * 2);
	postorder(root * 2 +1);
	if(inde ==0) cout<<a[root];
	else cout<<' '<<a[root];
	inde++;
}
int main(){
	cin>>m>>n;
	for(int i=0;i<m;i++){
		for(int j=1;j<=n;j++){
			cin>>a[j];
		}
		ismax(1);
		ismin(1);		
		if(flag ){
			cout<<"Max Heap"<<endl;
			postorder(1);
			cout<<endl;
		}
		else if(flag1 ){
			cout<<"Min Heap"<<endl;
			postorder(1);
			cout<<endl;
		}
		else{
			cout<<"Not Heap"<<endl;
			postorder(1);
			cout<<endl;
		}
		flag=true;
		flag1=true;
		inde=0;
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值