1078 Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10
​4
​​ ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:
4 4
10 6 4 15

Sample Output:
0 1 4 -

Quadratic 平方的,二次方的
这个单词是关键,
记得上数据结构的课是,老师说hash里面有3种方法,有提过二次方探查法,但是没认出来= =,题目还说了说不考虑负的方向探测,但是我做这道题有个地方卡了我好长时间,
这是我第一次做(错误版本 15分)

#include<cstdio>
#include<cmath>
#include<queue>
#include<iostream>
#include<algorithm>
#include<map>
#include<cstring>
const int maxn = 100010;;
using namespace std;
bool is_prime(int n){
	if(n == 1) return false;
	for(int i=2;i*i<=n;i++){
		if(n%i == 0) return false;
	}
	return true;
}
int cnt,none;
bool vis[maxn];
char result[maxn];
int main(){
	
	int m,n;
	cin>>m>>n;
	while(is_prime(m) == false) m++;

	for(int i=0;i<n;i++){
		int x;
		cin>>x;
			int flag = 0;
			for(int j=0;j<m;j++){
				int neww = (x+j*j) % m;
				if(vis[neww] == false){
					result[cnt++] = neww + '0';
					vis[neww] = true;
					flag = 1;
					break;
				}
			}
			if(flag == 0) result[cnt++] = '-';
	}
	for(int i=0;i<cnt;i++){
		if(i > 0) cout<<' ';
		cout<<result[i];
	}
	return 0;
}

改进过后

#include<cstdio>
#include<cmath>
#include<queue>
#include<iostream>
#include<algorithm>
#include<map>
#include<cstring>
const int maxn = 100010;
using namespace std;
bool is_prime(int n){
	if(n == 1) return false;
	for(int i=2;i*i<=n;i++){
		if(n%i == 0) return false;
	}
	return true;
}
int cnt,none;
bool vis[maxn];
int result[maxn];
int main(){
	
	int m,n;
	cin>>m>>n;
	while(is_prime(m) == false) m++;

	for(int i=0;i<n;i++){
		int x;
		cin>>x;
			int flag = 0;
			for(int j=0;j<m;j++){
				int neww = (x+j*j) % m;
				if(vis[neww] == false){
					result[cnt++] = neww ;
					vis[neww] = true;
					flag = 1;
					break;
				}
			}
			if(flag == 0) result[cnt++] = -1;
	}
	for(int i=0;i<cnt;i++){
		if(i > 0) cout<<' ';
		if(result[i] == -1) cout<<'-';
		else cout<<result[i];
	}
	return 0;
}

唯一不同的地方就是存储 ‘-’的地方,我一开始用char 数组存,但是我觉得没错啊,但是就是通不过,无奈是能这样做,我也不知道为什么,先记住把,唉

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值