POJ 2386 Lake Counting

POJ 2386 Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source

USACO 2004 November

题目链接

题目大意:
上下左右任意方向相邻的W为同一个Lake,问给定图有多少个Lake

题目思路:
每次BFS或DFS可访问一个W及相邻的所有W(一个Lake),并将它们标记为已访问。看所有W被访问完需要多少次搜索,即有多少个Lake

以BFS举例:从任意的一个W开始BFS,搜索到一个W就把它设置为非W,直至此次BFS结束,Lake的数量加1;再从剩余的W中进行BFS,同样操作至结束,Lake数量加1;当图中不存在W时,Lake即为所求。
同样原理的题目,这篇博客HDU1241,解法就是BFS。

但是此处采用DFS也可以解决

代码:

#include<iostream>
#include<cstdlib>
#include<string>
using namespace std;
int n, m;
char lake[101][101];

void dfs(int i,int j)
{
	lake[i][j] = '.';
	for (int p = -1; p<= 1; p++)
	{
		for (int q = -1; q <= 1; q++)
		{
			int a = i + p, b = j + q;
			if (a >= 1 && a <= n && b >= 1 && b <= m && lake[a][b] == 'W') dfs(a, b);
		}	
	}
}

int main()
{
	int sum = 0;
	cin >> n >> m;
	for (int i = 1; i <= n; i++)
	{
		string s;
		cin >> s;
		for (int j = 0; j < m; j++)
		{
			if (s[j] == '.')lake[i][j + 1] = '.';
			else lake[i][j + 1] = 'W';
		}
	}
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
			if (lake[i][j] == 'W') {
				dfs(i,j);
				sum++;
			}
	cout << sum << endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值