Coloring Game(快速幂函数)

David has a white board with 2×N2 \times N2×N grids.He decides to paint some grids black with his brush.He always starts at the top left corner and ends at the bottom right corner, where grids should be black ultimately.

Each time he can move his brush up(↑), down(↓), left(←), right(→), left up(↖), left down(↙), right up(↗), right down (↘) to the next grid.

For a grid visited before,the color is still black. Otherwise it changes from white to black.

David wants you to compute the number of different color schemes for a given board. Two color schemes are considered different if and only if the color of at least one corresponding position is different.
Input

One line including an integer n(0<n≤109)n(0<n \le 10^9)n(0<n≤109)
Output

One line including an integer, which represent the answer  mod 1000000007\bmod 1000000007mod1000000007
样例输入1

2

样例输出1

4

样例解释1
在这里插入图片描述

样例输入2

3

样例输出2

12

样例解释2
在这里插入图片描述

第一列和最后一列有两种情况,一块是黑的或者两块都是黑的;
剩下的列都有三种情况,一块是黑的两种情况,或者两块都是黑的。
所以n>=3时
总的个数为 sum = 3^(n-2)*4.
用到了快速幂的知识。
快速幂参考了这篇博客个人感觉写的很好(https://www.cnblogs.com/Howe-Young/p/4097277.html)

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>

using namespace std;

long long int power(long long int a,long long int b,long long int c)
{
    int res = 1;
    a = a%c;
    while(b)
    {
        if(b&1)
            res = (res*a)%c;
        a = (a*a)%c;
        b >>=1;
    }
    return res;
}
int main()
{
    long long int n;
    cin>>n;
    if(n==1)
        cout<<1<<endl;
    else if(n==2)
        cout<<4<<endl;
    else
    {
        long long int t = power(3,n-2,1000000007);
        t = t*4%1000000007;
        cout<<t<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值