Intersection -------HDU - 5120 (求两环相交的面积)

Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know. 


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below. 


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

Input

The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10). 

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places. 

Sample Input

2
2 3
0 0
0 0

2 3
0 0
5 0

Sample Output

Case #1: 15.707963
Case #2: 2.250778

题意:给出 一个数T,表示有多少种 数据。每组数据都包含R1,R2;X1,Y1;X2,Y2;

           R1,R2分别表示环的内外半径,X1,Y1;X2,Y2分别表示两个一样的环的环心(即圆的圆心)位置。

           求 两环相交 的部分的面积的大小。

思路:由画图知:相交的面积等于两环的外圆相交的面积—第一个环的外圆与第二个环的 内圆相交的面积—第一个环 的内                              圆与第二个环的外圆相交的面积+两环内圆相交的面积 

直接套用两圆相交的模板。。。。。。

 代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
#define pi acos(-1.0)//圆周率的表示方法
#define eps 1e-7
struct node
{
    double x;
    double y;
};
double len(double x1,double y1,double x2,double y2)
{
    double l=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)+0.0);
   // printf("%lf---->\n",l);
    return l;
}
double Area(node c1,double r1,node c2,double r2)
{
    //printf("%lf %lf %lf %lf>>>>>>\n",c1.x,c1.y,c2.x,c2.y);
    double d=len(c1.x,c1.y,c2.x,c2.y);
    if((r1+r2)<d+eps)
        return 0;
    if(d<fabs(r1-r2)+eps)
    {
        double r=min(r1,r2);
        return pi*r*r;
    }
    double ang1=acos((d*d+r1*r1-r2*r2)/(2*r1*d)*1.0);
    double ang2=acos((d*d+r2*r2-r1*r1)/(2*r2*d)*1.0);
    return ang1*r1*r1+ang2*r2*r2-d*r1*sin(ang1);
}
int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        double r1,r2;
        cin>>r1>>r2;
        node a,b;
        cin>>a.x>>a.y>>b.x>>b.y;
        //printf("%lf %lf %lf %lf>>>>>>>\n",a.x,a.y,b.x,b.y);
        double S=Area(a,r2,b,r2)-Area(a,r2,b,r1)-Area(a,r1,b,r2)+Area(a,r1,b,r1);
        printf("Case #%d: %.6lf\n",cas++,S);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值