1106 Lowest Price in Supply Chain (25 分)(读懂题目,树详解)

360 篇文章 3 订阅
91 篇文章 1 订阅

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10
5
), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K
j

being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10
10
.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

结尾无空行
Sample Output:

1.8362 2

结尾无空行

其实就是一个树的问题,每个非叶子结点都是供应商,每上升一层就涨固定利率的钱,只有叶子节点是经销商,与客户打交道,问客户买到的最小的价格和最小价格的经销商数量,其实就是问根节点的权值和最小权值根节点的个数。

本题,使用邻接表存储图,然后每次往深遍历,修改权重,遇到叶子结点,更新最小权重即可

#include<iostream>
#include<bits/stdc++.h>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<deque>
#include<unordered_set>
#include<unordered_map>
#include<cctype>
#include<algorithm>
#include<stack>
using namespace std;
const int N = 100001;
vector<int> v[N];
double min_price = 1e9;
int counts = 0;
int n;
double p, r;
void Dfs (int x, double price) {
	if (v[x].size() == 0) {// 根节点
		if (min_price > price) {
			min_price = price;
			counts = 1;
		} else if (min_price == price) {
			counts++;
		}
		return;
	}
	for (int i = 0; i < v[x].size(); i++) {
		Dfs(v[x][i], price * (1 + r / 100.0));
	}
}
int main() {	
	cin >> n >> p >> r;
	for (int i = 0; i < n; i++) {
		int k;
		cin >> k;
		while (k--) {
			int x;
			cin >> x;
			v[i].push_back(x);
		}
	}	
	Dfs(0, p);
	printf("%.4f %d", min_price, counts);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值