链路聚合 rstp 生成树阻塞 dhcp全局地址池与mac绑定 telnet ssh 环回接口 ospf

《傻狍子第五期》

咕咕咕 我又来了 今天是2020/3/25日 颓废了很多天吧 我来卖惨了!!!!
我tm一个配置视频看了三次才完成得迷迷糊糊 道理我都懂 就是配得烦emm错了不知道多少次啊啊啊啊(不说了 上图)
在这里插入图片描述在这里插入图片描述
1.提高可用性
将LSW1和LSW2之间的链路进行聚合,将LW1和LSW3之间的链路进行聚合;
将LSW1/LSW2/LSW2的生成树模式调整为RSTP模式,生成树被阻塞的接口为LSW2上的e0/0/3。
2.如图配置IP地址。
要求:AR1配置为DHCP-server。而AR2和AR3均为DHCP-client,分配到的地址一定要为图中地址。
使用AR2持续对AR3进行PING测试,当LSW2的聚合接口down时,可以在5个丢包数内完成恢复切换。
2.在AR2上配置telnet功能,要求使用"admin/huawei"登陆AR2进行网管。
3.在AR3上配置stelnet功能,要求使用"admin/huawei"登陆AR3进行网管,只允许stelnet这一种协议可以进行远程登陆使用。
4.在AR1/2/3/4四台设备上都配置loopback接口,地址为x.x.x.x/32,其中x为ARx的编号。
在AR1/2/3上运行OSPF,AR4不允许运行OSPF,要求AR2和AR3都可以使用loopback接口访问AR4的loopback。

(上面都是配置的目标 呜呜呜)
呐 这就是我这几天的作业 说难也不难 说简单也很简单 就是我这脑袋啊 像浆糊 (我不会告诉你们我一天只学一会就溜去玩了
我们开始吧:
聚合链路
target:
将LSW1和LSW2之间的链路进行聚合,将LW1和LSW3之间的链路进行聚合

<Huawei>system-view 
[Huawei]sysname LSW1
[LSW1]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]trunkport GigabitEthernet 0/0/1 to 0/0/2
[LSW1-Eth-Trunk1]quit 
[LSW1]interface Eth-Trunk 2
[LSW1-Eth-Trunk2]trunkport GigabitEthernet 0/0/3 to 0/0/4
[LSW1-Eth-Trunk2]display interface brief 检查聚合表

上面还只是配置了一半 做事都要有头有尾 我们还要在lw2 和lw3那边配个“车站”

[LSW2]interface Eth-Trunk 1 注意 我上面配置的w2是1
[LSW2-Eth-Trunk1]trunkport Ethernet 0/0/1 to 0/0/2 这里根据端口的类型来
然后跳到lsw3
[LSW3]interface Eth-Trunk 2 我上面w2是2
[LSW3-Eth-Trunk2]trunkport Ethernet 0/0/1 to 0/0/2 同上
老规矩 记得检查 

配置rstp和链路阻塞
target:
将LSW1/LSW2/LSW2的生成树模式调整为RSTP模式,生成树被阻塞的接口为LSW2上的e0/0/3

[LSW1]stp mode rstp 
进入LSW2
[LSW2]stp mode rstp 
进入LSW3
[LSW3]stp mode rstp 
以上生成树模式调整完毕 一下设置阻塞接口(我用的优先级)
[LSW1]stp priority 0
[LSW3]stp priority 4096

注意 我生成树的阻塞接口配置是这么想的:
我要阻塞的是w2的3接口 那么 我不管什么开销 毕竟都一样 我也不管什么mac我直接甩优先级 来的干脆emm
我将lsw1的优先级设为0 lsw1就是根
我将lsw3的优先级设为4096 lsw2就是指定根
那么自然而然 lsw2什么都不是 他的3端口只能阻塞作为备用端口

第二步
配置dhcp
target:
AR1配置为DHCP-server。而AR2和AR3均为DHCP-client,分配到的地址一定要为图中地址。

[AR1]dhcp enable 
[AR1]interface gigabitEthernet 0/0/0
[AR1-GigabitEthernet0/0/0]ip address 10.1.1.1 24
[AR1-GigabitEthernet0/0/0]dhcp select global ps:全局模式 
[AR1]ip pool 1 建立地址池
[AR1-ip-pool-1]network 10.1.1.0 mask 255.255.255.0 发地址
[AR1-ip-pool-1]static-bind ip-address 10.1.1.102 mac-address 00e0-fc68-3720 
上面这一步记得 要从对应的设备接口拿去mac地址
[AR1-ip-pool-1] static-bind ip-address 10.1.1.103 mac-address 00e0-fc78-6525
AR1的配置就算是做完了 然后就是去领配置了
[AR2-GigabitEthernet0/0/0]ip address dhcp-alloc 
AR2
[AR3-GigabitEthernet0/0/0]ip address dhcp-alloc 
AR3

第一步就是结束了 然后第二部 ping测试 害
rstp配置边缘端口
target:
使用AR2持续对AR3进行PING测试,当LSW2的聚合接口down时,可以在5个丢包数内完成恢复切换。

[LSW2]interface Ethernet0/0/4
[LSW2-Ethernet0/0/4]stp edged-port enable 
上是LSW2 下是LSW3
[LSW3]interface Ethernet0/0/4
[LSW3-Ethernet0/0/4]stp edged-port enable 

这个就配置完成了 边缘接口 完

然后配置网管
配置teinet
target:
在AR2上配置telnet功能,要求使用"admin/huawei"登陆AR2进行网管。

[AR2]user-interface vty 0 4
[AR2-ui-vty0-4]authentication-mode aaa
[AR2-aaa]local-user admin password cipher huawei privilege level 15
[AR2-aaa]local-user admin service-type telnet 

配置ssh
target:
在AR3上配置stelnet功能,要求使用"admin/huawei"登陆AR3进行网管,只允许stelnet这一种协议可以进行远程登陆使用

[LSW3]stelnet server  enable 
[LSW3]rsa local-key-pair create 设置钥匙加密 等级是1000
The key name will be: Host
% RSA keys defined for Host already exist.
Confirm to replace them? (y/n)[n]:y
The range of public key size is (512 ~ 2048).
NOTES: If the key modulus is greater than 512,
       It will take a few minutes.
Input the bits in the modulus[default = 512]:1000
[AR3]user-interface vty 0 4
[AR3-ui-vty0-4]authentication-mode aaa
[AR3-ui-vty0-4]protocol inbound ssh 只允许ssh登录使用
[AR3-ui-vty0-4]aaa
[AR3-aaa]local-user admin password cipher huawei privilege level 15
[AR3-aaa]local-user admin service-type ssh 类型是ssh
[AR2]ssh client first-time enable  在连接之前必须要开启协议

回环接口配置
target:
.在AR1/2/3/4四台设备上都配置loopback接口,地址为x.x.x.x/32,其中x为ARx的编号。

[AR1]int LoopBack 1
[AR1-LoopBack1]ip address 1.1.1.1 32 

[AR2]int LoopBack 1
[AR2-LoopBack1]ip address 2.2.2.2 32 

[AR3]int LoopBack 1
[AR3-LoopBack1]ip address 3.3.3.3 32 

[AR4]int LoopBack 1
[AR4-LoopBack1]ip address 4.4.4.4 32 

最后一步 配置ospf宣发
target:
在AR1/2/3上运行OSPF,AR4不允许运行OSPF,要求AR2和AR3都可以使用loopback接口访问AR4的loopback

[AR1]int LoopBack 0
[AR1-LoopBack0]ospf
[AR1-ospf-1]area 0
[AR1-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[AR1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0

[AR2]int LoopBack 0
[AR2-LoopBack0]ospf
[AR2-ospf-1]area 0
[AR2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
[AR1-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255

[AR3]int LoopBack 0
[AR3-LoopBack0]ospf
[AR3-ospf-1]area 0
[AR3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
[AR3-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255

[AR1]ip route-static 4.4.4.4 255.255.255.255 100.1.1.4
[AR1]ip route-static 0.0.0.0 0.0.0.0 100.1.1.1

[AR1]ospf
[AR1-ospf-1]default-route-advertise always 

到这里就结束了 说实话 这东西我写得心不在焉 真的 天天想偷懒 玩游戏 害 快颓废了 你要加油知道不 小子 以后看自己的苦逼日记之后要更加努力 不想多说了 奥里给 睡觉

2020/3/25 记住 老师很多个 而你只有一个 所以千万不要放弃

发布了6 篇原创文章 · 获赞 4 · 访问量 1430
App 阅读领勋章
微信扫码 下载APP
阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 游动-白 设计师: 上身试试

分享到微信朋友圈

×

扫一扫,手机浏览