走迷宫之bfs

走迷宫

给定一个 n×m的二维整数数组,用来表示一个迷宫,数组中只包含 0
或 1,其中 0表示可以走的路,1表示不可通过的墙壁。
最初,有一个人位于左上角 (1,1)处,已知该人每次可以向上、下、左、右任意一个方向移动一个位置。
请问,该人从左上角移动至右下角 (n,m)处,至少需要移动多少次。
数据保证 (1,1)处和 (n,m)处的数字为 0,且一定至少存在一条通路。
输入格式
第一行包含两个整数 n和 m。
接下来 n行,每行包含 m个整数(0或 1),表示完整的二维数组迷宫。
输出格式
输出一个整数,表示从左上角移动至右下角的最少移动次数。
数据范围
1≤n,m≤100
输入样例:
5 5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
8

#include<iostream>
#include<algorithm>
#include<queue>
#include <string.h>

using namespace std;

typedef pair<int,int>pii;

const int N=110;
int n,m;
pii q[N*N];
int g[N][N];
int d[N][N];

int bfs(){
    int hh = 0, tt = 0;
    q[0]={0,0};

    memset(d,-1,sizeof d);
    d[0][0] = 0;
    int dx[4] = {-1,0,1,0},dy[4] = {0,1,0,-1};
    while(hh<=tt){
        auto t=q[hh++];
        for(int i=0;i<4;i++){
            int x=t.first+dx[i],y=t.second+dy[i];
            if(x>=0 && x<n && y>=0 && y<m && g[x][y] == 0 && d[x][y] == -1){//d[x][y] == -1代表着还没有访问过,我们只找第一次到达的点
                d[x][y] = d[t.first][t.second] + 1;
                q[++tt] = {x,y};
            }
        }
    }
    return d[n-1][m-1];
}

int main(){
    cin>>n>>m;

    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            cin>>g[i][j];
        }
    }
    cout<<bfs()<<endl;
}

以下是Java中使用BFS算法解决走迷宫问题的示例代码: ```java import java.util.*; public class MazeBFS { static int[][] maze = {{0, 0, 0, 0, 0, 0, 0, 0}, {0, 1, 0, 1, 1, 1, 0, 0}, {0, 1, 0, 0, 0, 0, 0, 0}, {0, 1, 1, 1, 0, 1, 1, 0}, {0, 1, 0, 0, 0, 0, 1, 0}, {0, 1, 1, 1, 1, 1, 1, 0}, {0, 0, 0, 0, 0, 0, 0, 0}}; static int[][] direction = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}}; public static void main(String[] args) { int startX = 1; int startY = 1; int endX = 5; int endY = 6; Queue<Node> queue = new LinkedList<>(); boolean[][] visited = new boolean[maze.length][maze[0].length]; Node startNode = new Node(startX, startY, 0); queue.offer(startNode); visited[startX][startY] = true; while (!queue.isEmpty()) { Node node = queue.poll(); int x = node.x; int y = node.y; int step = node.step; if (x == endX && y == endY) { System.out.println(step); break; } for (int i = 0; i < 4; i++) { int nextX = x + direction[i][0]; int nextY = y + direction[i][1]; if (nextX >= 0 && nextX < maze.length && nextY >= 0 && nextY < maze[0].length && maze[nextX][nextY] == 0 && !visited[nextX][nextY]) { queue.offer(new Node(nextX, nextY, step + 1)); visited[nextX][nextY] = true; } } } } static class Node { int x; int y; int step; public Node(int x, int y, int step) { this.x = x; this.y = y; this.step = step; } } } ``` 在上述代码中,我们使用了一个Node类来表示迷宫中的每个节点,其中包含了x和y坐标以及当前步数step。我们使用一个队列来进行BFS搜索,并且使用一个二维布尔数组visited来记录每个节点是否已经被访问过。 我们从起点开始,将其加入队列中,并将其visited值设为true。然后不断从队列中取出节点进行搜索,直到队列为空或者找到终点为止。对于每个节点,我们尝试向四个方向扩展,如果扩展出来的节点在迷宫范围内、不是墙、没有被访问过,就将其加入队列中,并将visited值设为true。 最终,如果搜索到了终点,就输出步数并停止搜索。如果队列为空仍然没有找到终点,说明终点不可达。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值