PAT-A1048 Find Coins (寻找硬币)

"该博客介绍了一个关于寻找硬币组合以支付特定金额的问题。Eva需要使用恰好两个硬币来支付购物款项,而商场接受各种硬币。通过输入硬币面值和所需支付的金额,算法判断是否存在这样的硬币组合。代码示例展示了如何解决这个问题,包括对输入进行处理、查找可能的硬币组合,并在没有解决方案时输出"NoSolution"。"
摘要由CSDN通过智能技术生成

A1048 Find Coins (寻找硬币)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15结尾无空行

Sample Output 1:

4 11

结尾无空行

Sample Input 2:

7 14
1 8 7 2 4 11 15结尾无空行

Sample Output 2:

No Solution

结尾无空行

分析:

这道题目也不难,就是要注意当钱的数值是一样的时候,要看看是否有两个值

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std; 
bool HashTable[100010]={false};
int num[100010]={0};
int main(){
	int m,n,v1,v2,i;
	bool flag=false;
	int coin[100010];
	scanf("%d %d",&m,&n);
	for(int i=0;i<m;i++){
		scanf("%d",&coin[i]);
		num[coin[i]]++;
		HashTable[coin[i]]=true;
	}
	sort(coin,coin+m);
	int min=100;
	for(i=0;i<m;i++){
		if(HashTable[n-coin[i]]){//可以输出 
		if(coin[i]==(n-coin[i])){
			if(num[coin[i]]!=1){
				flag=true;
			    break;
			}
		}else{
			flag=true;
			break;
		}
			
		}
	}
	if(flag) printf("%d %d",coin[i],n-coin[i]);
	else printf("No Solution");
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值