Pig-Latin

You have decided that PGP encryptation is not strong enough for your email. You have decided to
supplement it by first converting your clear text letter into Pig Latin before encrypting it with PGP.
Input and Output
You are to write a program that will take in an arbitrary number of lines of text and output it in Pig
Latin. Each line of text will contain one or more words. A “word” is defined as a consecutive sequence
of letters (upper and/or lower case). Words should be converted to Pig Latin according to the following
rules (non-words should be output exactly as they appear in the input):

  1. Words that begin with a vowel (a, e, i, o, or u, and the capital versions of these) should just
    have the string “ay” (not including the quotes) appended to it. For example, “apple” becomes
    “appleay”.
  2. Words that begin with a consonant (any letter than is not A, a, E, e, I, i, O, o, U or u) should
    have the first consonant removed and appended to the end of the word, and then appending “ay”
    as well. For example, “hello” becomes “ellohay”.
  3. Do not change the case of any letter.
    Sample Input
    This is the input.
    Sample Output
    hisTay isay hetay inputay.
#include<iostream>
using namespace std;
char temp[1005];
int isab(char c)
//是否是字母
{
	if(c>='a'&&c<='z')
	return 1;
	if(c>='A'&&c<='Z')
	return 1;
	return 0;
}
//是否是元音字母
int vowel(char c) 
{
	if(c=='a'||c=='e'||c=='i'||c=='o'||c=='u')
	return 1;
	if(c=='A'||c=='E'||c=='I'||c=='O'||c=='U')
	return 1;
	return 0;
}
int main()
{
	while(gets(temp))//输入字符串数组 
	{
		int s=0,t=0;//设置两个标志变量 
		while(temp[s])
		//如果不是字母,那么直接输出 
			if(!isab(temp[s]))
			{
				printf("%c",temp[s++]);//temp[0]输出,s+1 
				t=s; 
			} 
			 else
			     if(isab(temp[s]))//是字母 
			      t++;
			     else
			    {
			 			
			          if(!vowel(temp[s]))//辅音字母开头 
			         {
			        	for(int i=s+1;i<t;++i)
			        	printf("%c",temp[i]);// 
			     	 printf("%c",temp[s]);//
			         }
			         else
		            	for(int i=s;i<t;++i)//以元音字母开头,i 
		            	printf("%c",temp[i]);//输出元音字母开头的单词 
		            printf("ay");
		            s=t;//
				  
		       	}
	
		printf("\n");
	}
	return 0;
}
	
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值