Flink运行报错 No ExecutorFactory found to execute the application.

报错信息

在这里插入图片描述

报错原因

从Flink1.11开始,移除了flink-streaming-java对flink-clients的依赖,需要手动加入clients依赖。

解决方法

修改pom文件,添加 flink-clients依赖

 <dependency>
        <groupId>org.apache.flink</groupId>
        <artifactId>flink-clients_2.12</artifactId>
        <version>1.12.2</version>
 </dependency>
已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 1024 设计师:白松林 返回首页