Soilers(士兵站队问题)

这篇博客讨论了一个涉及N个士兵在Gridland中重新排列的问题。每个士兵的位置由一对整数坐标表示,目标是让所有士兵水平排列,并最小化他们到达此状态所需的总移动步数。输入包含士兵的初始位置,输出为达到目标配置的最小总步数。提供的C++代码实现了这一算法,通过排序和计算每个士兵到中心点的距离来找出最优解。
摘要由CSDN通过智能技术生成

N soldiers of the land Gridland are randomly scattered around the country.
A position in Gridland is given by a pair (x,y) of integer coordinates. Soldiers can move - in one move, one soldier can go one unit up, down, left or right (hence, he can change either his x or his y coordinate by 1 or -1).

The soldiers want to get into a horizontal line next to each other (so that their final positions are (x,y), (x+1,y), …, (x+N-1,y), for some x and y). Integers x and y, as well as the final order of soldiers along the horizontal line is arbitrary.

The goal is to minimise the total number of moves of all the soldiers that takes them into such configuration.

Two or more soldiers must never occupy the same position at the same time.
Input
The first line of the input contains the integer N, 1 <= N <= 10000, the number of soldiers.
The following N lines of the input contain initial positions of the soldiers : for each i, 1 <= i <= N, the (i+1)st line of the input file contains a pair of integers x[i] and y[i] separated by a single blank character, representing the coordinates of the ith soldier, -10000 <= x[i],y[i] <= 10000.
Output
The first and the only line of the output should contain the minimum total number of moves that takes the soldiers into a horizontal line next to each other.
Sample Input
5
1 2
2 2
1 3
3 -2
3 3
Sample Output
8
在这里插入图片描述

#include<iostream>
#include<stdio.H>
#include<math.h>
#include<algorithm>
using namespace std;
int x[10005];
int y[10005];

int main()
{
    int n;
    while(~scanf("%d",&n)){
        int stepx=0;
        int stepy=0;
        int steps=0;
        for(int i=0;i<n;i++){
            scanf("%d%d",&x[i],&y[i]);
        }
        sort(x,x+n);//先给坐标排序
        sort(y,y+n);
        for(int i=0;i<n;i++){
            x[i]-=i;//站成连续的一排,所以减去连续的数字,得到移动的x步数数组
        }
        sort(x,x+n);//再次排序
        for(int i=0;i<n;i++){
            steps+=abs(x[i]-x[n/2])+abs(y[i]-y[n/2]);
        }
        printf("%d\n",steps);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值