PTA Have Fun with Numbers python

PTA数据结构能力自测 自测-4 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

输入格式:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

输出格式:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

输入样例:

1234567899

输出样例:

Yes
2469135798

解题思路:

1.本题的大致意思是给出一个数a,将该数乘2后得到数b,若a和b里所包含的数字完全一样,则输出Yes,反之输出No,并在最后打印数b
2.对于python来说直接得到数b然后利用sort()函数暴力求解就好。

代码如下

n = input()
a = []
b = []
for i in n:
    a.append(i)
n = int(n)
m = n*2
m = str(m)
for j in m:
    b.append(j)
a.sort()
b.sort()
if a == b:
    print('Yes')
    print(int(m))
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值