1080 Graduate Admission (30 分)

1080 Graduate Admission (30 分)

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​ , and the interview grade G​I​​ . The final grade of an applicant is (G​E​​ +G​I​​ )/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​ . If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:
Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G​E​​ and G​I​​ , respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:
0 10
3
5 6 7
2 8

1 4

题目大意:
给定n个考生,m个院校。每个考生有两个成绩GE和GI,还有k个志愿。将考生按总分排序,如果总分相同,则按成绩GE排序;若也相同,则二者排名一致。排名靠前的人可以优先选择目标院校(按照志愿顺序下来),但不能超过目标院校的招生人数。要求输出每个院校的招生情况。
特殊情况:当院校名额已满,但该考生的前一个人分数和录取院校都与该考生相同,此时可以破格收录

算法分析:
设立结构体数组存储考生信息,maxnum数组存储每个院校的招生人数,vector数组v存储院校的招生情况。

对结构体数组进行排序,排名高的学生先进行选择,被收录的学生压入对应的vector中,vector.size()就是对应院校的招生人数

注意最后输出时id是乱的,和一开始输入的顺序不同

AC代码:

#include<bits/stdc++.h>
using namespace std;
struct node{
	int ge,gi,rank,id;
	vector<int> choice;
};
int cmp(node a,node b){
	if(a.ge+a.gi!=b.ge+b.gi)
	return a.ge+a.gi>b.ge+b.gi;
	return a.ge>b.ge;
}
int main()
{
	int n,m,k;
	cin>>n>>m>>k;
	node applicant[n];//存储每个候选人的信息 
	int maxnum[m];//存储每个学校的招生数量 
	for(int i=0;i<m;i++)
	scanf("%d",&maxnum[i]);
	vector<int> v[m];
	for(int i=0;i<n;i++){
		applicant[i].choice.resize(k);//注意resize后只能通过下标赋值 
		applicant[i].id=i;
		scanf("%d %d",&applicant[i].ge,&applicant[i].gi);
		for(int j=0;j<k;j++)
		scanf("%d",&applicant[i].choice[j]);
	}
	sort(applicant,applicant+n,cmp);
	applicant[0].rank=1;
	for(int i=1;i<n;i++){
		if(applicant[i].ge+applicant[i].gi==applicant[i-1].ge+applicant[i-1].gi&&applicant[i].ge==applicant[i-1].ge)
		applicant[i].rank=applicant[i-1].rank;//若分数都一样,排名与前一个相同 
		else
		applicant[i].rank=i+1;
	}
	int frontchoice;
	for(int i=0;i<n;i++){
		int flag=0;
		for(int j=0;j<k;j++){
			int choice=applicant[i].choice[j];
			if(v[choice].size()<maxnum[choice]||(choice==frontchoice&&applicant[i].rank==applicant[i-1].rank)){
				//总分与选择和前一个相同的可以超额收入 
				v[choice].push_back(applicant[i].id);
				flag=1;
				frontchoice=choice;
				break;
			}
		}
		if(flag==0)
		frontchoice=-1;//若没有被学校招收,frontchoice变为-1 
	}
	for(int i=0;i<m;i++){
		sort(v[i].begin(),v[i].end());
		if(v[i].size()==0){
			printf("\n");
		}
		else{
			printf("%d",v[i][0]);
			for(int j=1;j<v[i].size();j++){
				printf(" %d",v[i][j]);
			}
			printf("\n");
		}
	}
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值