1102 Invert a Binary Tree (25 分)

1102 Invert a Binary Tree (25 分)
The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -

0 -
2 7

5 -
4 6

Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题目大意:
给定一棵树,将它反转(交换每个结点的左右子结点),输出它的层序遍历和中序遍历

算法分析:
结构体数组存储树的信息。用队列实现层序遍历:
1、首先将二叉树的根节点push到队列中,判断队列不为NULL,就输出队头的元素,
2、判断节点如果有孩子,就将孩子push到队列中,
3、遍历过的节点出队列,
4、循环以上操作,直到Tree == NULL。

再用中序遍历模板

AC代码:

#include<bits/stdc++.h>
using namespace std;
int num;
struct node{
	int l,r;
};
node tree[11];
void levelorder(int index){//用队列实现层序遍历 
	queue<int> q;
	q.push(index);
	int flag=0;
	while(!q.empty()){
		int temp=q.front();
		q.pop();//弹出队首结点,如果该结点有左右子结点,则将它们依次压入 
		if(flag==1)
		printf(" ");
		cout<<temp;
		if(tree[temp].l!=-1)
		q.push(tree[temp].l);
		if(tree[temp].r!=-1)
		q.push(tree[temp].r);
		flag=1;
	}
	printf("\n");
}
int cnt;
void inorder(int root){//中序遍历,左右根 
	if(tree[root].l!=-1)
	inorder(tree[root].l);
	cout<<root;
	++cnt==num?cout<<"":cout<<" ";
	if(tree[root].r!=-1)
	inorder(tree[root].r);
}
int main()
{
	for(int i=0;i<11;i++)
	tree[i].l=tree[i].r=-1;//结构体元素不能直接初始化,需要另做赋值 
	scanf("%d",&num);
	set<int> temp;
	char a,b;
	for(int i=0;i<num;i++){
		getchar();
		scanf("%c %c",&a,&b);
		if(a>='0'&&a<='9'){
			tree[i].r=a-'0';
			temp.insert(tree[i].r);
		}
		if(b>='0'&&b<='9'){
			tree[i].l=b-'0';
			temp.insert(tree[i].l);
		}
	}
	int root;
	for(int i=0;i<num;i++){
		if(temp.find(i)==temp.end()){
			root=i;
			break;
		}
	}
	//在左右子结点中没有出现过的就是根结点 
	levelorder(root);
	inorder(root);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值