华为网络综合项目

拓扑图

在这里插入图片描述

项目目的

通过配置单臂路由、OSPF、RIP、引入路由、Easy IP、MSTP技术来实现公司内部网络能够访问互联网。

项目步骤

1.路由R1配置

interface GigabitEthernet0/0/0
 ip address 202.10.102.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 210.10.101.1 255.255.255.0 

2.路由R2配置

acl number 2000  
 rule 5 permit source 192.168.0.0 0.0.31.255
 
 interface GigabitEthernet0/0/0
 ip address 210.10.101.2 255.255.255.0 
 nat outbound 2000
#
interface GigabitEthernet0/0/1
 ip address 192.168.15.2 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 192.168.16.2 255.255.255.0 
#
interface GigabitEthernet2/0/0
 ip address 192.168.10.2 255.255.255.0 

 ospf 110 router-id 2.2.2.2 
 default-route-advertise always
 area 0.0.0.0 
  network 2.2.2.2 0.0.0.0 
  network 192.168.10.0 0.0.0.255 
  network 192.168.15.0 0.0.0.255 
  network 192.168.16.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 210.10.101.1

3.路由R3配置

interface GigabitEthernet0/0/0
 ip address 192.168.10.3 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.20.3 255.255.255.0 
 
ospf 110 
 import-route rip 1 cost 100
 area 0.0.0.0 
  network 192.168.10.0 0.0.0.255 
#
rip 1
 undo summary
 default-route originate
 version 2
 network 192.168.20.0
 import-route ospf 110 cost 0

4.路由R4配置

interface GigabitEthernet0/0/0
 ip address 192.168.20.4 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.30.4 255.255.255.0 
 
rip 1
 undo summary
 version 2
 network 192.168.20.0
 network 192.168.30.0

5.路由R5配置

interface GigabitEthernet0/0/0
 ip address 192.168.30.5 255.255.255.0 
 
interface GigabitEthernet0/0/1.1
 dot1q termination vid 500
 ip address 192.168.5.5 255.255.255.0 
 arp broadcast enable
#
interface GigabitEthernet0/0/1.2
 dot1q termination vid 600
 ip address 192.168.6.5 255.255.255.0 
 arp broadcast enable
 
 rip 1
 undo summary
 version 2
 network 192.168.30.0
 network 192.168.5.0
 network 192.168.6.0             RIP宣告

6.三层交换机LW2配置

vlan batch 100 200 300 400 555
#
stp instance 1 root primary
stp instance 2 root secondary
stp region-configuration
 region-name huawei
 revision-level 1
 instance 1 vlan 100 200
 instance 2 vlan 300 400
 active region-configuration        stp生成树
 
 interface Vlanif100
 ip address 192.168.1.10 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.1.1
 vrrp vrid 1 priority 105
 vrrp vrid 1 track interface GigabitEthernet0/0/1
#
interface Vlanif200
 ip address 192.168.2.10 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.2.1
 vrrp vrid 2 priority 105
 vrrp vrid 2 track interface GigabitEthernet0/0/1
#
interface Vlanif300
 ip address 192.168.3.10 255.255.255.0
 vrrp vrid 3 virtual-ip 192.168.3.1
#
interface Vlanif400
 ip address 192.168.4.10 255.255.255.0
 vrrp vrid 4 virtual-ip 192.168.4.1
#
interface Vlanif555
 ip address 192.168.15.10 255.255.255.0
 
 interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 555
#
interface GigabitEthernet0/0/2
 eth-trunk 1
#
interface GigabitEthernet0/0/3
 eth-trunk 1
#
interface GigabitEthernet0/0/4
 eth-trunk 1
#
interface GigabitEthernet0/0/5
 eth-trunk 1
#
interface GigabitEthernet0/0/6
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/7
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 
 ospf 110 router-id 6.6.6.6
 area 0.0.0.0
  network 192.168.1.0 0.0.0.255
  network 192.168.2.0 0.0.0.255
  network 192.168.3.0 0.0.0.255
  network 192.168.4.0 0.0.0.255
  network 192.168.15.0 0.0.0.255

7.三层交换机LW3配置

vlan batch 100 200 300 400 666
#
stp instance 1 root primary
stp region-configuration
 region-name huawei
 revision-level 1
 instance 1 vlan 100 200
 instance 2 vlan 300 400
 active region-configuration

interface Vlanif100
 ip address 192.168.1.11 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.1.1
#
interface Vlanif200
 ip address 192.168.2.11 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.2.1
#
interface Vlanif300
 ip address 192.168.3.11 255.255.255.0
 vrrp vrid 3 virtual-ip 192.168.3.1
 vrrp vrid 3 priority 105
 vrrp vrid 3 track interface GigabitEthernet0/0/1
#
interface Vlanif400
 ip address 192.168.4.11 255.255.255.0
 vrrp vrid 4 virtual-ip 192.168.4.1
 vrrp vrid 4 priority 105
 vrrp vrid 4 track interface GigabitEthernet0/0/1
#
interface Vlanif666
 ip address 192.168.16.10 255.255.255.0

interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 666
#
interface GigabitEthernet0/0/2
 eth-trunk 1
#
interface GigabitEthernet0/0/3
 eth-trunk 1
#
interface GigabitEthernet0/0/4
 eth-trunk 1
#
interface GigabitEthernet0/0/5
 eth-trunk 1
#
interface GigabitEthernet0/0/6
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/7
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

ospf 110 router-id 7.7.7.7
 area 0.0.0.0
  network 192.168.1.0 0.0.0.255
  network 192.168.2.0 0.0.0.255
  network 192.168.3.0 0.0.0.255
  network 192.168.4.0 0.0.0.255
  network 192.168.16.0 0.0.0.255

8.二层交换机LW4配置

stp region-configuration
 region-name huawei
 revision-level 1
 instance 1 vlan 100 200
 instance 2 vlan 300 400
 active region-configuration
 
interface Ethernet0/0/1
 port link-type access
 port default vlan 100
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 200

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

9.二层交换机LW5配置

vlan batch 300 400

stp region-configuration
 region-name huawei
 revision-level 1
 instance 1 vlan 100 200 300 400
 active region-configuration
 
interface Ethernet0/0/1
 port link-type access
 port default vlan 300
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 400
 
 interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

10.二层交换机LW6配置

vlan batch 500 600

interface Ethernet0/0/1
 port link-type access
 port default vlan 500
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 600

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

项目结果

在这里插入图片描述
在这里插入图片描述

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页