L1-5 胎压监测

小轿车中有一个系统随时监测四个车轮的胎压,如果四轮胎压不是很平衡,则可能对行车造成严重的影响。

让我们把四个车轮 —— 左前轮、右前轮、右后轮、左后轮 —— 顺次编号为 1、2、3、4。本题就请你编写一个监测程序,随时监测四轮的胎压,并给出正确的报警信息。报警规则如下:

  • 如果所有轮胎的压力值与它们中的最大值误差在一个给定阈值内,并且都不低于系统设定的最低报警胎压,则说明情况正常,不报警;
  • 如果存在一个轮胎的压力值与它们中的最大值误差超过了阈值,或者低于系统设定的最低报警胎压,则不仅要报警,而且要给出可能漏气的轮胎的准确位置;
  • 如果存在两个或两个以上轮胎的压力值与它们中的最大值误差超过了阈值,或者低于系统设定的最低报警胎压,则报警要求检查所有轮胎。

输入格式:

输入在一行中给出 6 个 [0, 400] 范围内的整数,依次为 1~4 号轮胎的胎压、最低报警胎压、以及胎压差的阈值。

输出格式:

根据输入的胎压值给出对应信息:

  • 如果不用报警,输出 Normal
  • 如果有一个轮胎需要报警,输出 Warning: please check #X!,其中 X 是出问题的轮胎的编号;
  • 如果需要检查所有轮胎,输出 Warning: please check all the tires!

输入样例 1:

242 251 231 248 230 20

输出样例 1:

Normal

输入样例 2:

242 251 232 248 230 10

输出样例 2:

Warning: please check #3!

输入样例 3:

240 251 232 248 240 10

输出样例 3:

Warning: please check all the tires!

C++代码 :

#include<iostream>
using namespace std;
int main()
{
	int a,b,c,d,min,cha,mx,w=0;
	int w1=0,w2=0,w3=0,w4=0;
	cin>>a>>b>>c>>d>>min>>cha;
	mx=max(max(a,b),max(c,d));
	if(a>=min&&b>=min&&c>=min&&d>=min&&(mx-a)<=cha&&(mx-b)<=cha&&(mx-c)<=cha&&(mx-d)<=cha)
			cout<<"Normal";
	else
	{
		if((mx-a)>cha||a<min)
		w1++;
		if((mx-b)>cha||b<min)
		w2++;
		if((mx-c)>cha||c<min)
		w3++;
		if((mx-d)>cha||d<min)
		w4++;
	
	if(w1==1)
	w++;
	if(w2==1)
	w++;
	if(w3==1)
	w++;
	if(w4==1)
	w++;
	
	if(w>1)
	printf("Warning: please check all the tires!");
	else 
	{
		if(w1==1)
		printf("Warning: please check #1!");
		if(w2==1)
		printf("Warning: please check #2!");
		if(w3==1)
		printf("Warning: please check #3!");
		if(w4==1)
		printf("Warning: please check #4!");
	}
}
	return 0;
}

java代码:

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner scanner = new Scanner( System.in);
        int [][] tab = new int[4][2];
        int m = 0;
        int i , j ;
        for(i = 0;i<4;i++)
        {
            tab[i][0]=scanner.nextInt();
            tab[i][1]=1;
        }
        int min = scanner.nextInt(), cha = scanner.nextInt();
        for(i = 0 ;i<3;i++)
        {
            for(j =i;j<4;j++)
            {
                int k = tab[i][0]-tab[j][0];
                k= k>0?k:-k;
                if(k>cha)
                    tab[i][1] = 0;

                if(tab[j][0]<min)
                    tab[j][1]=0;
            }
        }
        for(i = 0;i< 4 ;i++)
        {
            if(tab[i][1]==0)
                m++;
        }
        if(flag == 0)
            System.out.println("Normal");
        else if(m<=1)
        {
            for( i= 0 ;i<4;i++)
            {
                if(tab[i][1]==0)
                    System.out.println("Warning: please check #" + (i+1) + "!");
            }
        }
        else
            System.out.println("Warning: please check all the tires!");
    }
}

评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

谦谦孑

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值