C - The Frog‘s Games (贪心)

The annual Games in frogs’ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog’s longest jump distance).
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Output
For each case, output a integer standing for the frog’s ability at least they should have.

Sample Input
6 1 2
2
25 3 3
11
2
18

Sample Output
4
11

题目大意:
青蛙跳石头过河,最多跳m步,问青蛙至少拥有的跳跃能力(一步跳多远)。

解题思路:

  • 排序数组,模拟河中的石头,最后添加河对岸
  • 二分枚举答案,每一步在跳跃能力范围内尽量跳在更远的石头上,记录到达河对岸的步数
  • 如果步数>m,说明跳跃力不足,l=m+1,否则恰好是答案,或则跳跃力过强,r=m;

完整代码:

#include<iostream>
using namespace std;
int main() {
	int n,n2;
	int a[100010];
	int ma=0;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>a[i];
		ma=max(ma,a[i]);
	}
	cin>>n2;
	if(n2==1){
		cout<<ma<<endl;
		return 0;
	}
	int l=0,r=ma,m;
	while(r>l){
		m=(r+l)/2;
		long long sum=0;
		for(int i=0;i<n;i++){
			if(a[i]>m){
				sum+=(a[i]-m)/(n2-1)+((a[i]-m)%(n2-1)!=0);
			}
		}
		if(sum>m){
			l=m+1;
		}else{
			r=m;
		}
	}
	cout<<l;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值