1002 Business (35 分)

As the manager of your company, you have to carefully consider, for each project, the time taken to finish it, the deadline, and the profit you can gain, in order to decide if your group should take this project. For example, given 3 projects as the following:

  • Project[1] takes 3 days, it must be finished in 3 days in order to gain 6 units of profit.
  • Project[2] takes 2 days, it must be finished in 2 days in order to gain 3 units of profit.
  • Project[3] takes 1 day only, it must be finished in 3 days in order to gain 4 units of profit.

You may take Project[1] to gain 6 units of profit. But if you take Project[2] first, then you will have 1 day left to complete Project[3] just in time, and hence gain 7 units of profit in total. Notice that once you decide to work on a project, you have to do it from beginning to the end without any interruption.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤50), and then followed by N lines of projects, each contains three numbers P, L, and D where P is the profit, L the lasting days of the project, and D the deadline. It is guaranteed that L is never more than D, and all the numbers are non-negative integers.

Output Specification:

For each test case, output in a line the maximum profit you can gain.

Sample Input:

4
7 1 3
10 2 3
6 1 2
5 1 1

Sample Output:

18

 

#include <iostream>
#include <algorithm>
using namespace std;
const int N = 55;
const int MAX = 1e5;
struct Project
{
    int p,l,d;
    bool operator <(const Project x) const{
            return d < x.d;
    }
} a[N];

int dp[N][MAX];

int main()
{
    int n;
    cin>>n;
    int maxx = 0;
    for(int i = 1; i <= n; ++i)
    {
        cin>>a[i].p>>a[i].l>>a[i].d;
        maxx = max(maxx,a[i].d);
    }
    sort(a+1,a+n+1);
    for(int i = 1; i <= n; ++i)
    {
        for(int j = 1; j <= maxx; ++j)
        {
            if(j <= a[i].d)
                if(j - a[i].l < 0)
                    dp[i][j] = dp[i-1][j];
                else if(j - a[i].l == 0)
                    dp[i][j] = max(dp[i-1][j],a[i].p);
                else
                    dp[i][j] = max(dp[i-1][j],dp[i-1][j-a[i].l]+a[i].p);
            else
                dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
        }
    }
    cout<<dp[n][maxx]<<endl;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值