Bad Cowtractors

4 篇文章 0 订阅

题目描述

Bessie has been hired to build a cheap internet network among Farmer John’s N (2 <= N <= 1,000) barns that are conveniently numbered 1…N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn’t even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a “tree”.# 一、pandas是什么?

示例:pandas 是基于NumPy 的一种工具,该工具是为了解决数据分析任务而创建的。

输入

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

输出

  • Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

样例输入

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

样例输出

42

#include <bits/stdc++.h>
using std::cin;
using std::cout;
using std::endl;
using std::sort;
struct node{
    int pre, nxt, w;
}edge[20010];
int fa[1010], k;
long long int ans;
bool cmp(node a, node b) {
	return a.w > b.w;
}
int getfa(int i)
{
    if (fa[i] != i)
        fa[i] = getfa(fa[i]);
    return fa[i];
}
int xxx()
{
    sort(edge, edge + k, cmp);
    for (int i = 0; i < k; i++)
    {
        int a, b;
        a = getfa(edge[i].pre), b = getfa(edge[i].nxt);
        if (a != b) {
            fa[a] = b;
            ans += edge[i].w;
        }
    }
    return ans;
}
int main()
{
    int n, m;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        k = 0;
        ans = 0;
        for (int i = 1; i <= n; i++)
            fa[i] = i;
        while (m--)
        {
            cin >> edge[k].pre >> edge[k].nxt >> edge[k].w;
            k++;
        }
        ans = xxx();
        int cnt = 0;
        for (int i = 1; i <= n; i++)
        {
            if (fa[i] == i)
                cnt++;
        }
        if (cnt > 1) cout << "-1" << endl;
        else cout << ans << endl;
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值