链表的逆序输出(链表)

链表的逆序输出(链表)

题目描述

按数字输入顺序创建单链表。不可借助数组、容器,不可改变原链表、不可开辟新结点空间(输出链表时)。编程实现单链表的逆序输出。

输入

测试次数t

每组测试数据一行,格式如下:

数据个数n,后跟n个整数

输出

对每组测试数据,逆序输出单链表。

示例输入

2
10 1 2 3 4 5 6 7 8 9 10
4 19 20 15 -10

示例输出

10 9 8 7 6 5 4 3 2 1
-10 15 20 19

#include<iostream>
using namespace std;

struct Node
{
	int data;
	Node *next;	
};

Node *create(Node *&head);
void change(Node *head);
void distory(Node *head);
int main()
{
	int t,i,m,n;
	cin>>t;
	
	for(i=0;i<t;i++)
	{
		Node *head=NULL;
		change(create(head));
		cout<<endl;
		distory(head);
	}
	return 0;
}

Node *create(Node *&head)
{
	int n;
	cin>>n;
	Node *tail;
	for(int i=0;i<n;i++)
	{
		Node *p=new Node;
		cin>>p->data;
		if(head==NULL)
		head=p;
		else
		{
			tail->next=p;
		}		
			tail=p;
				
		
	}
	tail->next=NULL;
	return head;
}

void change(Node *head)
{
	if(head->next==NULL)
	{
		cout<<head->data<<" ";
		return ;
	}
	else if(head->next)
	change(head->next);
	cout<<head->data<<" ";
	return ;
}


void distory(Node *head)
{
	Node *p;
	while(head->next)
	{
		p=head->next;
		head->next=p->next;
		delete p;
	}
	delete head;
}
  • 3
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值