7-8 InputMismatchException异常 (20 分)

33 篇文章 4 订阅

(InputMismatchException异常)编写一个程序,提示用户读取两个整数,然后显示它们的和。程序应该在输入不正确时提示用户再次读取数值。

输入格式:
输入多组两个数

输出格式:
输出两个数的和

输入样例:
在这里给出一组输入。例如:

1  3
2.0  3
3.0  4
4  5

输出样例:
在这里给出相应的输出。例如:

sum = 4
Incorrect input: two integer is required
Incorrect input: two integer is required
sum = 9

import java.util.InputMismatchException;
import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
       while (true){
           try{
               int a= sc.nextInt();
               int b= sc.nextInt();
               System.out.println("sum = "+(a+b));
           }catch (InputMismatchException e){
               System.out.println("Incorrect input: two integer is required");
                sc.nextLine();
                /*第一次读取的nextInt读取完会残留一个回车在缓冲区中,不吸取掉回车,
                后面的nextInt会直接读取到回车,从而导致死循环*/
           }
       }
    }
}
  • 2
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值